**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. The free trial lasts for 30 days, after which you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

incoming calls do not ring

threepwoodthreepwood FreedomPop Newbie Posts: 6
Brand new to freedompop (2 days). Freedompop phone works in all functions EXCEPT incoming calls would not ring. phone is a Moto E. I can text, I can call out, etc. but whether or not phone will ring on an incoming call is pot luck. Updated all as recommended by diagnositics. But still, At times, it was goes straight to voice mail after 1 ring on caller end. I researched here and set push notification fixer to 3 minutes and this helped somewhat. Phone would ring somewhere between 3rd and 6th ring that caller hears. But occasionally will still go straight to voice mail on first ring. Phone still has never rung on first caller ring! It is a basic function that the phone should ring when called. How can you possibly expect me to continue a paid service when the phone can not perform the most basic functions of a phone !!! Even my 10 cents a minute net10 flip phone rings on the first ring. Any suggestions would be welcomed.

Answers

  • Mike WilderMike Wilder FreedomPop Newbie Posts: 3
    Same problem here, any answers yet?
  • threepwoodthreepwood FreedomPop Newbie Posts: 6
    Never received any answer here. Well, I made it better by installing PNF N0-root app and setting it to 3 minutes. I also went into settings and found a place where I could set notifications to wake up phone on calls and messages, unbelievably it was not checked by default. And finally, I saw that the phone was automatically going into sleep mode every nite so I turned that off also. For 3 days now, it has been ringing. Knock on wood it continues. Hope this helps.
  • kerstuffkerstuff FreedomPop Newbie Posts: 623 ✭✭✭
    When using Fpop I found that u will hsve problems with premium voice over WiFi. You have to disable it in your account settings. It is designed for weak signal use only.
  • dav8ordav8or FreedomPop Newbie Posts: 1
    In case you haven't found it or if someone else needs the answer, go into the messaging app, open the menu at the top left of the screen then choose settings >Call. From there click Notification listener rate. Try changing the value to a lower number. Mine was initially set at 300 seconds and incoming calls would not ring. I changed it to 30 seconds and calls ring through right away. I am sure that a longer period would help to reduce battery usage so I will experiment with it a bit. This in on an Android phone by the way.
  • Richard LaugesenRichard Laugesen FreedomPop Newbie Posts: 1
    What worked for us was to go into the app settings, then Call settings, and click on Premium Voice, then change to receiving calls with the app rather than premium voice. (I am guessing that our signal strength is low here, and since we could not receive calls at premium voice quality, the system would send the call straight to voicemail.) We don't need premium voice anyway. So, problem solved.
  • GreenguruGreenguru FreedomPop Newbie Posts: 4
    thanks RL
  • GreenguruGreenguru FreedomPop Newbie Posts: 4

    What worked for us was to go into the app settings, then Call settings, and click on Premium Voice, then change to receiving calls with the app rather than premium voice. (I am guessing that our signal strength is low here, and since we could not receive calls at premium voice quality, the system would send the call straight to voicemail.) We don't need premium voice anyway. So, problem solved.

    THANKS RL
  • ToppingCToppingC FreedomPop Newbie Posts: 1
    I have try those solutions without results. iPhone 5 FreedomPop ver 6.1 #129-32
    FreedomPop is a waste of time!
  • valleevallee FreedomPop Newbie Posts: 5
    On our new iPhone we could not get the phone to ring till I went into FreedomPop settings went into "Call Settings" and receive "Call via" and changed "App" unmaking "Premium Voice" and the phone now rings perfectly. This is what Kerstuff recommended above.
  • jyzhangjyzhang FreedomPop Newbie Posts: 1
    I am having this exact issue with my Android phone as well. The incoming call won't ring the phone unless the FP Messaging App is open or just opened it a short while ago.

    With the new version of the FP Messaging App, there is no "Call Settings" in the setting menu. Am I missing something?
Sign In or Register to comment.