One Final Plea...

Wilson DingWilson Ding Posts: 1FreedomPop Newbie
Hey Freedompop,

This is my condensed story (I wrote out everything, but it was 1813 characters too long)

Bought Samsung Galaxy S3
Phone arrives, unable to activate
Talks to support, told me my phone isn't in the system
Realizes I can't receive calls, send or receive texts
Talks to support
-Did the following: Reinstall, PRL/Profile Update, Force Close/Clear Data, MSL Reset, Factory Reset, Firmware Reflash
Talks to support again, transferred to "level 2 support", sent ticket to "development team"
Promised a resolution email within 2 days (never received)
Phone starts receiving calls, still can't send/receive texts
My comments/posts are seeming to not be "approved" and are no longer showing up in the forums
Phone no longer receives calls

I just want my phone to work. I really love the idea of this company, and I've already spent ~$200 to support this company. I would really hate to have to ask for a refund, and to take my business elsewhere. Please help.

Comments

  • M.A. II LopezM.A. II Lopez Posts: 1,163FreedomPop Master, FreedomPop Expert ✭✭✭
    @Wilson Ding‌ Holly molly Wilson, has anyone reached out to you yet on this issue? Either @Darla_A‌ or @Mike‌ our moderators can assist you with that if it has not been responded to you yet! Also have you visited our forum for that device and sought out help from a FP Pro with that device? They may have already lived through that problem and gotten a resolution you can use!
  • Wilson DingWilson Ding Posts: 1FreedomPop Newbie
    @Taylor‌ @Darla_A‌ can either of you please help? My comments and this post finally went through a few days ago, and now my phone can once again receive calls. However, I still can not send or receive text messages.
  • Ali Ali Posts: 6,705FreedomPop Master, Test Role, iOS Master ✭✭✭✭✭
    @Wilson Ding‌ Looks like the development team came through for you and fixed your calling. If you re install the app and then wait for 24 hours, you probably can start texting again. Does data work for you now?
  • Wilson DingWilson Ding Posts: 1FreedomPop Newbie
    @Miguel, no one has reached out. :( I've tried messaging Darla and Taylor... Idk who mike is, but I might give it a try. I've visited the forums, and tried everything I could find on there... sadly, no luck!
  • CapeCoralCapeCoral Posts: 0FreedomPop Newbie
    I tried to set up by byod Galaxy S3 today- FB activation process told me that phone did not work at my address, huh?- so I switched screens and went through the process to buy an S3- guess what? FP said that phone works at my address. I know it's a good phone and I have LTE at my address- I was done, this was a bad omen for me- I needed a working phone asap. Time for plan B.
    30 minutes later, my phone was activated and working on RingPlus mobile and my phone was downloading updates- 30 more minutes and KitKat was pushed and installed automatically. I guess I can live with $9.99mo and a real phone number/sms text-
  • M.A. II LopezM.A. II Lopez Posts: 1,163FreedomPop Master, FreedomPop Expert ✭✭✭
    @Taylor‌ can you help Wilson out with this issue.
    @CapeCoral‌ sorry about your issue and sorry that you are not with FreedomPop. I am sure if you had brought the issue to our moderators here you might have gotten a better result. But it seems you still got a good deal though!
    PS we have real numbers and sms too!
  • @Wilson Ding‌ I have looked in to your account, and it looks like you were requested to get an ICCID number. Are you still having issues with your account?
  • Wilson DingWilson Ding Posts: 1FreedomPop Newbie
    @K_Ber‌, I don't really know what that means.... What is an ICCID number? Yes, I am still having trouble with my account. I am still unable to send or receive texts.
  • @Wilson Ding‌ An ICCID number is the number assigned to your SIM card. You can find it by looking in your phone's About page in the settings. Settings > About > Status.
Sign In or Register to comment.