**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. The free trial lasts for 30 days, after which you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY
If you have not recently performed a Carrier Reset to your mobile device, we recommend doing so to ensure that your FreedomPop service is operating to its best capability. This does not cause the loss of any information saved on your mobile device. You can find instructions by selecting the following link: https://support.freedompop.com/app/answers/detail/a_id/3017/

For additional topics related to your concern, please visit our online Self-Help Knowledge Base at https://support.freedompop.com

Add freedomfriend by email

Ching LuiChing Lui FreedomPop Newbie Posts: 6
Hi,

Before, I can add multiple email all at once. Now your system change to Type in One email address here at a time. I did that, but I check the sent invitation and see all email at the end is cut off by one letter. For example, .com missing M and it was changed to .co instead. Same with all email I type one by one manually. I asked my friends if they received my invitation and they didn't see it under their account so they can't accept and they tried to send one to me and same thing happen.

Any error on your side since this change?

Can you change back to allow multiple email entry by comma after each email?

Answers

  • erik123erik123 FreedomPop Newbie Posts: 9
    If you add an extra letter like .comm, the email will be sent to the address as if you typed .com.
  • HAO YEHAO YE FreedomPop Newbie Posts: 4
    Doesn't work. Adding extra letter .comm sends to .comm, not .com. Looks like the webpage has some errors.
    erik123 said:

    If you add an extra letter like .comm, the email will be sent to the address as if you typed .com.

  • Ching LuiChing Lui FreedomPop Newbie Posts: 6
    As I said, I typed .com and it came out to be .co
    I typed .net and it came out .ne

    I know what I wrote is correct and some is copy and paste and still have same affect.

    Therefore, freedompop should look into this matter.
  • DejayDejay FreedomPop Newbie, FP Flyer Posts: 22
    Hmm. That is odd. And that's unusual. So this happened once the new rules kicked in? Hmm. This has to be fixed on their end. Or just try and refresh your web browser too.
  • Ching LuiChing Lui FreedomPop Newbie Posts: 6
    I tried everything on the book and nothing work. And same with my friends accounts.

    Maybe freedompop don't want us to add friends anymore.

    Thanks to all that answer.
  • Lakeisha MillerLakeisha Miller FreedomPop Newbie Posts: 2
    Can I just send email friend request
  • Jeffrey BurgerJeffrey Burger FreedomPop Newbie Posts: 132
    edited September 23 #8
    FWIW, I notice that the at the alternate FreedomPop account site, my.freedompop.com it does still indicate comma separated email addresses can be entered. I've not used that (didn't know it was there), but have used the one at a time email address entry at www.freedompop.com with no problems over the last few days.
    Post edited by Jeffrey Burger on
  • kocat177kocat177 FreedomPop Newbie Posts: 26
    please add me - jessrussso254@gmail.com
  • kocat177kocat177 FreedomPop Newbie Posts: 26
    please add me jessrusso254 at gmail
  • Rich Sias (16th)Rich Sias (16th) FreedomPop Newbie, FreedomPop Master, FreedomPop Expert Posts: 2,643 ✭✭✭✭✭
    Need lots of 'friends' ? You will need to 'join' this group before getting access. There is a secure chat room setup here:
    https://forums.freedompop.com/group/5-freedompop-friends-connect
    Be my Valentine ZTE, Victory, LG Volt, & 803S
  • kocat177kocat177 FreedomPop Newbie Posts: 26
    how do I join ? There is not a join button anywhere. ? I also messaged Ali the group leader but he hasn't replied yet. How do I join. I really want to join
  • Jeffrey BurgerJeffrey Burger FreedomPop Newbie Posts: 132
    If the group here isn't functioning, there's a freedompop friends posting on slickdeals. I went to the last few pages and got email addresses to invite, rather than posting mine. Either way works to quickly accumulate friends.
Sign In or Register to comment.