Freedompop.com website

WQGJ587WQGJ587 Posts: 2FreedomPop Newbie
When I try to load www.freedompop.com website, it forwards to a Spanish site. I can not get it to load an English site to save my life unless I load the support page. However, I can not load the main Freedompop website.
Anyone know how I can correct this?

when I type this
www.freedompop.com
it redirects and loads this
https://es.freedompop.com/es?experience=organic.default

i cant locate anywhere on the Spanish page to change language either.
Tom

Answers

  • Rich Sias (16th)Rich Sias (16th) Posts: 3,348FreedomPop Newbie, FreedomPop Master, FreedomPop Expert ✭✭✭✭✭
    try this: https://us.freedompop.com Does that work any better for you ?

    Is your ISP associated with Spain in any way ? Are you maybe using a VPN that might be saying its IP is in Spain ?
    Be my Valentine ZTE, Victory, LG Volt, 803S, & 4 SIMs
  • Jeffrey BurgerJeffrey Burger Posts: 319FreedomPop Newbie ✭✭✭
    I had looked at the site they have for service in Spain once...might have been freedompop.es.

    After that my browser kept defaulting to that site. Anyway, I think I fixed it by deleting some of the browser data. It was a while ago so don't remember exactly what worked, but you might try deleting: cache, cookies and site data, and content settings. In looking at this in chrome settings, those are the things that I think I tried.
Sign In or Register to comment.