**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

Overdrive delivered in non-functional condition; "Connection Error (67) Network connection failed."

I bought the Overdrive, and it was delivered in non-functional condition. When I turn it on, it says "Connection Error (67) Network connection failed." I found instructions on the forum that explained how to deal with this issue, but the device I got is not behaving as the directions in the forum indicate. Pressing the power button twice does nothing (not matter how fast or slow I double-tap). The power button LED keeps flashing about once every eight seconds. With a computer I can detect the wifi signal from the device, but the wifi is password protected, with no way to access the password. I tried connecting the device using a USB cable to three different computers, and none could establish a connection to the device through the cable. If there is something else I can try to get this device working, let me know. Otherwise, please tell me how to return it. I am looking forward to using your service with a functional device!

Comments

  • EdwinFreedomPopEdwinFreedomPop FreedomPop Newbie, US Support Posts: 60 admin
    @frugalgrove‌ You can reset the Overdrive to its factory defaults. You can find a visual of how to do the process in the user manual linked at:

    http://tinyurl.com/y4yzzcy

    The instructions are located on pages 106-107. You will need a paper clip or pin for this.
  • cbalcerzakcbalcerzak FreedomPop Newbie Posts: 1
    I experienced this issue just yesterday. To resolve I did the following.

    1. Attach box by USB to a computer. Browser to 192.168.0.1

    2. Choose Advanced Settings.

    3. Choose "WAN" tab

    4. Under network updates, choose "Update 3g PRL", after it completes then "Update 3g profile". Wait several minutes, then restart.

    Had to perform Step 4 multiple times before it corrected itself.

    Hope this helps.
Sign In or Register to comment.