Phone Won't Use New Sim, Reverts to Older Sim

drs305drs305 Posts: 6FreedomPop Newbie
I have seen similar posts but so far have been unable to resolve my issue.
I have two FP LTE sims, each under a separate email address.
The first sim works flawlessly.
When I insert the second sim (LG Harmony) the phone works fine, but it uses my original sim's account and displays the original phone number in Messaging.

I have tried:
Delete App cache/data.
Deleting App cache/data and then uninstalling/reinstalling Messaging after restart,
Logging in to the FP Internet site using my second account before doing the above.
Booting w/o the sim card installed - oddly the phone worked anyway...

No matter what I've tried, Messaging always opens to the old phone number and that is where the usage is deducted. BTW, several posts discuss logging out of Messaging, but I see no way to log out. When I've uninstalled the app, upon rebooting the FP data is downloaded but I'm never asked which account to use.
Also, I've disabled Google sync just in case it was retrieving Sim 1's data during the reinstallation of Messaging.

Any suggestions?

Comments

  • [Deleted User][Deleted User] Posts: 0 admin
    The user and all related content has been deleted.
  • drs305drs305 Posts: 6FreedomPop Newbie
    AlejandraG,
    Thank you for taking the time to reply.

    I have tried "Sync" but it didn't help.

    During my trials, at one point I did get to the login prompt and used the phone number. Still no success. One thing I haven't figured out is how you "log out" of the Messaging app, which I seen some members suggest in earlier threads regarding similar issues. I can get to the Messaging screen displaying my username/phone number but can't find a logout link on either that page or settings.

    You probably know the answer to this one - my phone worked even with the sim card removed (albeit on the old number). Either it was linking to GV via wifi or FP writes info from the SIM card onto the phone's memory. Do you know which?
  • [Deleted User][Deleted User] Posts: 3,553
    The user and all related content has been deleted.
  • drs305drs305 Posts: 6FreedomPop Newbie
    Somehow my latest response didn't post.

    The combination of the two responses above solved my issue - thank you!

    Here are the steps I took following the recommendations above:
    a. Turned off Google Sync, just in case it was reloading old settings when I reinstalled apps.
    b. Turned off wifi.
    c. Settings > Storage (Internal or SD card, depending on where Messaging is installed) > Apps > Messaging > Clear Cache/Data (I didn't uninstall Messaging this time, just cleared the cache).
    d. Rebooted with phone/data enabled, wifi off.
    e. Opened Messaging. At this point Messaging restored some files, and allowed me to sign in using my new email/phone number.
    f. At this point the phone recognized my new/second FP number.
    g. Made a call and confirmed on the FP site that the minutes were deducted from the proper account.

    The important thing I hadn't tried previously that seemed to work was turning off wifi.

    Thanks to you both for your help. :-)
  • [Deleted User][Deleted User] Posts: 0 admin
    The user and all related content has been deleted.
  • drs305drs305 Posts: 6FreedomPop Newbie
    Thank you both for solving this riddle.

    Turning off Wifi seems to have done the trick, in combination with a couple of other steps.
    a. Turned off wifi.
    b. Deleted cache via Storage, Internal or SD card (depending where app is stored), Apps, Messaging, Clear Data (and Cache).
    c. Rebooted with data enabled but not wifi.
    d. When I opened Messaging, it re-downloaded some info and I was able to enter my second number,/email which it accepted.
    Minutes were charged to my second Sim account.
    The only other thing that I'd mention is that it's possible my Google account was also resyncing my old data when I previously uninstalled/reinstalled Messaging. I had turned that off before I started Step a.

    So thanks again for your assistance! I'm new to this forum but I don't see a SOLVED button, but feel free to do so if it's possible...
This discussion has been closed.