Where is connection optimizer on my Galaxy S4?

XenuXenu Posts: 8FreedomPop Newbie
Well I'm at Starbucks and the phone is refusing to make calls when not connected to their stressed out wifi, which gives horrendous QOS. The phone is showing 6 bars on the mobile network icon but not 3g, 4g or LTE. I think I possibly somehow turned connection optimizer on but I'm not sure because I never found anything specifically labeled as such and still can't find it to turn it off. I have a Galaxy S4 purchased from FP and I'm looking in settings->connections->more networks->mobile networks. The choices available are 1. Mobile Data, 2. Network Mode, 3. Access Point Names, and 4. Network Operators, which is greyed out. I looked in a bunch of other places too but didn't find it anywhere so either it's called something else on this phone or I don't have it. Please advise.

Best Answer

Answers

  • MiFi 4082MiFi 4082 Posts: 32FreedomPop Newbie
    I have an FP S3 (so not sure if it the same) but my "Sprint Connection Optimizer" was an Native Sprint App that had to be accepted or rejected when it first connected (I did not accept). Have you looked in Settings>Application Manager>ALL? Just an idea.
  • @Xenu‌ If you are having network connectivity issues, please try a PRL update. Here's how to do this:
    1. Select the menu button
    2. Tap settings, then scroll down to system updates
    3. Select update profile and let it run fully (may take up to 90 seconds)
    4. After the network profile is updated, repeat the same steps, but this time select update PRL instead of update profile

    Please let me know if this does not work for you, thanks!
  • XenuXenu Posts: 8FreedomPop Newbie
    Yup, Sprinter, I did look there. Thanks for the thought anyway.

    Thanks, K_BER, but I don't find any "System Updates" anywhere in my settings. Not under the Device tab, the Connections tab, the Accounts tab, or the More tab. I have very limited experience with Android, but maybe they changed things with KitKat 4.4.2, which my phone is running. I do have a "FreedomPop Config" app with an Update button but it didn't seem to do much. Maybe I need to find someplace with good 4G connectivity for it to work properly. I also found an "Auto Network Switch under advanced Wi-Fi settings and turned that on. It's too early yet to say if that helped but I'll let you know.
  • hankjrodhankjrod Posts: 368FreedomPop Newbie, FreedomPop Expert ✭✭✭
    Xenu said:

    Yup, Sprinter, I did look there. Thanks for the thought anyway.

    Thanks, K_BER, but I don't find any "System Updates" anywhere in my settings. Not under the Device tab, the Connections tab, the Accounts tab, or the More tab. I have very limited experience with Android, but maybe they changed things with KitKat 4.4.2, which my phone is running. I do have a "FreedomPop Config" app with an Update button but it didn't seem to do much. Maybe I need to find someplace with good 4G connectivity for it to work properly. I also found an "Auto Network Switch under advanced Wi-Fi settings and turned that on. It's too early yet to say if that helped but I'll let you know.

    The auto-network switched caused me to have problems connecting to wifi, so I turned it off.
  • XenuXenu Posts: 8FreedomPop Newbie
    Hmmm, well turning on Auto Network actually does seem to have solved my original problem of the annoying messages demanding that I connect to wifi in order to make a call. Now I can just use the phone without worrying about what kind of connection I'm using.
    hankjrod said:


    The auto-network switched caused me to have problems connecting to wifi, so I turned it off.

    Well, hankjrod, so far I have not had any wifi connection problems since I turned on Auto Network yesterday, and I have used wifi at two different Starbucks and at my buddy's house. YMMV?

    Now I still want to know how to do a profile/PRL update on this phone. Having read a few other posts on the subject, it seems my Settings GUI is not the same as what most other people have because I'm not finding anything in there labeled "Connection Optimizer" or "System Update."

  • XenuXenu Posts: 8FreedomPop Newbie
    K_Ber said:

    @Xenu‌ To perform a PRL update, please try this method instead:
    1. Open the native dialer and make sure you are connected to either LTE or WiFi
    2. Dial ##873283# and press call

    Thanks, K_Ber. I sat next to the wifi router and did the update. Although my original problem had already been solved by turning Auto Network on, it's still probably better to have updated it than not. It updated both profile and PRL within about ten seconds and I didn't even have to press call.

  • Richard AllenRichard Allen Posts: 644FreedomPop Newbie, FreedomPop Expert, Porting Master ✭✭✭✭
    @‌ xenu
    I copied these instructions from the sprint support page for updating the prl on a Samsung S4


    Steps to update the PRL on your Samsung Galaxy S4


    From the home screen, tap Apps.
    Scroll to and tap Settings.
    Tap More.
    Scroll to and tap System Update.
    Tap Update PRL and wait until it completes.
    Tap OK.
    You've now updated the PRL.

  • XenuXenu Posts: 8FreedomPop Newbie
    K_Ber said:

    @Xenu‌ To perform a PRL update, please try this method instead:
    1. Open the native dialer and make sure you are connected to either LTE or WiFi
    2. Dial ##873283# and press call

    Thanks, K_Ber. I sat next to the wifi router and did the update. Although my original problem had already been solved by turning Auto Network on, it's still probably better to have updated it than not. It updated both profile and PRL within about ten seconds and I didn't even have to press call.

  • @Xenu‌ That's great, I'm glad you were able to resolve your issue! If you have any more questions for us in the future, just let me know and I would be happy to help :)
Sign In or Register to comment.