**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

Trouble posting a question

rpaluszakrpaluszak FreedomPop Newbie Posts: 7
I am a new user and posted a question yesterday in the discussion category "Using Your Device". However, I don't see it listed. I also don't see a place to look at your history. Is there a large delay from posting to when it appears? If there is a delay, can you see the status of your post? How can you see your history of posts?

I bought a hotspot from FP and believe it is defective? How do I get a replacement. Other than this forum, I don't see any other way. Voice calls cost money. I tried "Submit a Ticket" and that failed.

Best Answer

Answers

  • rpaluszakrpaluszak FreedomPop Newbie Posts: 7
    I posted it on Sunday. But it still hasn't appeared. Even though, this post appeared.
    BTW, maybe you could answer the question form my original post. I am a new user and the device I received is defective (does not power up). I tried to "submit a ticket" to support but it was denied - saying that I am not a VIP customer. How do I reach out to FreedomPop to get a replacement?
  • Rich Sias (16th)Rich Sias (16th) FreedomPop Newbie, FreedomPop Master, FreedomPop Expert Posts: 3,112 ✭✭✭✭✭
    @rpaluszak - here is a good place to post. Not sure what happened to the Sunday post. It should have been approved about the same time as the 2nd one was approved.
    When you tried to submit a ticket was it to this - https://support.freedompop.com ? Or was it to [email protected] that you sent an email ? It seems odd that after dozens of months of convincing people to NOT phone but to use electronic submissions for assistance that they now are trying to block that too ?

    Anyway if you tried only one of the 2 above, try the other one.
    If an admin drops in on this conversation, they have the authority to arrange a replacement after they determine that it cannot be made to work for you. A few simple questions may be all they need answered.

    Have you tried removing the battery and then using the charger to power the device. Many but not all will work this way. THEN you might know that it is just a bad battery. That can be arranged to get you another battery.
    While the battery is out, find the battery part number or model number and search on eBay. Find out of state but USA source for the SAME battery printing as yours. Do NOT buy one with a non exact same label. Original batteries can be found between $6 & $13 depending on model. Chinese companies copy builds but do so poorly that it will barely be better than the bad battery. My batteries last 9-18 months. Depending on how many times I run way over on overcharging the battery. I'd suggest ordering a 2nd one on eBay. I like having a spare battery already charged up. Maybe 80%+ is still in it a month later. Only 3 minutes and I have a fully charged phone instead of several hours. Sometimes I can 't wait several hours.
    Be my Valentine ZTE, Victory, LG Volt, 803S, & 4 SIMs
  • rpaluszakrpaluszak FreedomPop Newbie Posts: 7
    Thanks. Yes, if I remove the battery I can power the device and use the hotspot as expected, with no troubles connecting to the internet.
    I came to the same conclusion that it is most likely a defective battery.
    I did price them on eBay and will buy a backup from eBay. For two reasons, when travelling, it is not always convenient to recharge the battery and having a spare would extend my usage in this situation; second batteries do fail, when travelling, it might not be till I get back home that I could replace it and I would be without till then.
    However, this is a new device that I just got and expect it to work. I do understand why they don't offer free phone service. But, there should be some way to submit an online ticket for an issue that is best suited for an employee who could issue an RMA for a battery. I would doubt that any user/community person would be able to help with an RMA. For an RMA, the logical person to reach out to would be an employee.
    I guess, I am just frustrated, in that I have no means to reach support, the public forum is flawed in that my first post got lost and the second took days to appear. I am also frustrated in that the "Submit a Ticket" option is blocked and you don't get notice of it until after you type in all the information and your question and hit submit. I have now spent, almost a week and getting nowhere after numerous attempts. The submit a ticket is a feature of "https://support.freedompop.com". I wasn't aware of any other URL to submit a ticket online. If you have another link that would be great.
  • AlejandraGAlejandraG FreedomPop Newbie Posts: 4,111 admin
    rpaluszak said:

    Thanks. Yes, if I remove the battery I can power the device and use the hotspot as expected, with no troubles connecting to the internet.
    I came to the same conclusion that it is most likely a defective battery.
    I did price them on eBay and will buy a backup from eBay. For two reasons, when travelling, it is not always convenient to recharge the battery and having a spare would extend my usage in this situation; second batteries do fail, when travelling, it might not be till I get back home that I could replace it and I would be without till then.
    However, this is a new device that I just got and expect it to work. I do understand why they don't offer free phone service. But, there should be some way to submit an online ticket for an issue that is best suited for an employee who could issue an RMA for a battery. I would doubt that any user/community person would be able to help with an RMA. For an RMA, the logical person to reach out to would be an employee.
    I guess, I am just frustrated, in that I have no means to reach support, the public forum is flawed in that my first post got lost and the second took days to appear. I am also frustrated in that the "Submit a Ticket" option is blocked and you don't get notice of it until after you type in all the information and your question and hit submit. I have now spent, almost a week and getting nowhere after numerous attempts. The submit a ticket is a feature of "https://support.freedompop.com". I wasn't aware of any other URL to submit a ticket online. If you have another link that would be great.

    We understand your frustration considering the battery of the new device is not working properly. Can you please confirm the device's MEID number?
    This way we will be able to locate the account and check about the possibility to send a replacement battery and/or an exchange is within warranty.
This discussion has been closed.