can't get wifi tethering working on this newly purchased Galaxy S3 phone

Deanna MahDeanna Mah Posts: 0FreedomPop Newbie
Hi folks: has anyone else received an FP Galaxy S3 phone and been able to use it as a wifi hotspot?

I bought this phone over the other phones (that were on sale at woot.com) because FP's FAQ page -- and the Freedompop representative in the woot forum -- stated that the Galaxy S3 phone would allow wifi tethering.

I've attempted numerous times to enable wifi tethering on the phone. Under Settings-Connection, when I attempt to enable "FreedomPop hotspot"; I get the following error messages:

“hotspot error --
you are not subscribed to the hotspot service, do you want to see subscription options?
Cancel or OK.

OK gets:
Welcome to self service (grayed out). Then:
Self Service: Information:sorry experienced a system problem during your task, please call custom care at 888-211-4727 from another phone”

I've called the phone number above with no success; the Sprint agent tells me that this is not their phone and not their problem. I hope someone at FP can help.

Comments

  • Michael  AndersonMichael Anderson Posts: 0FreedomPop Newbie
    Ok, I called the good folks at support. You need to upgrade to freedompop phone premier (free trial period, then 9.99), then update the PRL and Profile. Then turn on hotspot and check for the hotspot signal on the device you're connecting to. It will ask for a security key. You might have to call support to setup your password. They say they will send an email with instructions. I've been waiting for 10 minutes for the email to arrive, hopefully it will arrive shortly.
  • Michael  AndersonMichael Anderson Posts: 0FreedomPop Newbie
    Now they say you need freedompop Phone Premier to access wifi hotspot. I found out today that I have freedompop phone premier, and was charged for it, although I never ordered it! So I figured I'd try the wifi hotspot, and it still doesn't work!! I don't know, man......
  • Sprinter GS3Sprinter GS3 Posts: 6FreedomPop Newbie
    @Vanessa What is FreedomPop's attitude towards the user installing an app that enables this function? And any idea when it might become available (ball park?)
  • Ali Ali Posts: 6,735FreedomPop Master, Test Role, iOS Master ✭✭✭✭✭
    @Sprinter GS3‌ You can use an app like CWM tether or TrevEMod. The latter option requires a root and that makes your device ineligible for any support from FreedomPop. It is possible to get tethering working natively if you subscribe to premier or use the unlimited data plan.
  • Michael  AndersonMichael Anderson Posts: 0FreedomPop Newbie
    Update: I have been waiting all day for that email. No idea what password to use when activating Freedompop Wifi Hotspot tethering. That email was supposed to give me instructions on how to setup the password.
  • Ali Ali Posts: 6,735FreedomPop Master, Test Role, iOS Master ✭✭✭✭✭
    You can use any SSID and Password for the WiFi hotspot on your phone, it should be able to work without any issues.
  • jblalockjblalock Posts: 5FreedomPop Newbie
    I have the unlimited plan and I'm having the same problem. I just decided I'd buy the hotspot service for like $4 and have it for my iphone, which I don't have a carrier for, but all I keep getting is that same error message. If I'm getting jipped out of a service I've paid for because they want me to keep buying other things for it to work I'm going to be mad. bought the service yesterday and I'm still having the same problem..
Sign In or Register to comment.