**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

Auto top-up not working and Data = 0?

ianojiianoji FreedomPop Newbie Posts: 5
Hello,

On my account, which was working fine until Dec.31.2018, I can't connect to internet on my hotspot anymore.

The account says "Data left = 0", but it's a brand new month. The auto top-up toggle will not stay in the "YES" position. Whenever I log out and come back, it's back to "NO".

I updated the credit card info in Billing just in case.

Can you please re-activate the account?

Thanks!

Answers

  • AlejandraGAlejandraG FreedomPop Newbie Posts: 4,803 admin
    ianoji said:

    Hello,

    On my account, which was working fine until Dec.31.2018, I can't connect to internet on my hotspot anymore.

    The account says "Data left = 0", but it's a brand new month. The auto top-up toggle will not stay in the "YES" position. Whenever I log out and come back, it's back to "NO".

    I updated the credit card info in Billing just in case.

    Can you please re-activate the account?

    Thanks!

    It seems there is an issue with the payment information documented for that account.
    Please update it to be able to re-establish a connection.
  • ianojiianoji FreedomPop Newbie Posts: 5
    I have re-updated the Credit Card information.
    There was a notification about a "$20.00 hold that will not be actually charged".

    Auto Top-up still doesn't want to stay as "YES".

    Please check again if that is the fix? Thank you!
  • AlejandraGAlejandraG FreedomPop Newbie Posts: 4,803 admin
    ianoji said:

    I have re-updated the Credit Card information.
    There was a notification about a "$20.00 hold that will not be actually charged".

    Auto Top-up still doesn't want to stay as "YES".

    Please check again if that is the fix? Thank you!

    ianoji said:

    I have re-updated the Credit Card information.
    There was a notification about a "$20.00 hold that will not be actually charged".

    Auto Top-up still doesn't want to stay as "YES".

    Please check again if that is the fix? Thank you!

    Our payment system has recently been updated and this is the reason why some credit/debit cards or Paypal accounts are not being accepted, you will need to try a new payment, just re-updating the one that was documented will not work.

    We currently accept all major credit cards and debit (not prepaid, gift or virtual) cards . We accept VISA, MasterCard, Discover, and American Express.

    Also, make sure to follow the next steps to perform the update on your payment info:
    1) Use a PC and not your mobile
    2) Clear cookies and Cache of the web browser, preferably Chrome or Firefox and/or using an incognito or private window.
    3) Follow the steps above from a different IP connection
  • ianojiianoji FreedomPop Newbie Posts: 5
    Thank you, on a second credit card, it works now.
  • AlejandraGAlejandraG FreedomPop Newbie Posts: 4,803 admin
    ianoji said:

    Thank you, on a second credit card, it works now.

    We are glad to learn it is now working, please let us know if we can help with some else.
This discussion has been closed.