**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

my new hotspot quit working after 2 days of use

jimbatesjimbates Posts: 15FreedomPop Newbie
I just received my mingle hotspot less than a week ago, and it was working okay after about 2 days of use. Then I went to plug it in to the cord and it just went black and will no longer power up. I already marked this in black sharpie (so I know what account it belonged to), but now the problem is it won't work and I need to return it. I already broke down the blue box it came it, and also the shipping box, but I can reassemble the shipping box if needed. Please give me complete instructions for exchanging this device. Message me and I will send you my account address. Thanks for your help.

Best Answer

Answers

  • AlejandraGAlejandraG Posts: 5,164FreedomPop Newbie admin
    edited February 8 #3
    jimbates said:

    I just received my mingle hotspot less than a week ago, and it was working okay after about 2 days of use. Then I went to plug it in to the cord and it just went black and will no longer power up. I already marked this in black sharpie (so I know what account it belonged to), but now the problem is it won't work and I need to return it. I already broke down the blue box it came it, and also the shipping box, but I can reassemble the shipping box if needed. Please give me complete instructions for exchanging this device. Message me and I will send you my account address. Thanks for your help.

    We are sorry to learn it is not working. Please confirm your device's MEID number to look into this.
  • jimbatesjimbates Posts: 15FreedomPop Newbie
    My MEI 089700070900262673
  • jimbatesjimbates Posts: 15FreedomPop Newbie
    My MEI: 089700070900262673
  • CarlosGCarlosG Posts: 983 admin
    jimbates said:

    My MEI: 089700070900262673

    We have escalated your case to our support team who will be looking into your request ASAP. The moment we have an answer, we'll send you all the details of their response.
  • jimbatesjimbates Posts: 15FreedomPop Newbie
    Did you get my MEID number? I posted it here but I don't see it showing.
  • jimbatesjimbates Posts: 15FreedomPop Newbie
    I keep posting my MEID but it is not showing up. Please send me a PM.
  • jimbatesjimbates Posts: 15FreedomPop Newbie
    For some reason, my hotspot started working again (MEI: 089700070900262673) and has been working fine since. It seems it was a battery issue, seems to have run out of charge -- battery was at 0% charge, but its holding charge fine now. I want to keep this hotspot and cancel return please. I have not been able to get online though, I think because you altered my device or cancelled it from my account. Please be sure that I can continue to use this on my account. It keeps showing only 3G available, when my other mingle is having no problem getting 4G.
  • CarlosGCarlosG Posts: 983 admin
    jimbates said:

    For some reason, my hotspot started working again (MEI: 089700070900262673) and has been working fine since. It seems it was a battery issue, seems to have run out of charge -- battery was at 0% charge, but its holding charge fine now. I want to keep this hotspot and cancel return please. I have not been able to get online though, I think because you altered my device or cancelled it from my account. Please be sure that I can continue to use this on my account. It keeps showing only 3G available, when my other mingle is having no problem getting 4G.

    We have reactivated this hotspot. Please try to use it and let us know if it works properly and if you are able to get the best connection on it.
  • jimbatesjimbates Posts: 15FreedomPop Newbie
    Hello, yes, it is working properly and the connection quality is the same as my other hotspots. Thank you for your help!
  • CarlosGCarlosG Posts: 983 admin
    jimbates said:

    Hello, yes, it is working properly and the connection quality is the same as my other hotspots. Thank you for your help!

    I'm happy to help. Have a great day!
This discussion has been closed.