GS4 only 3g

Christian MattisonChristian Mattison Posts: 1FreedomPop Newbie
Hi, I bought a Galaxy S4 for use with your BYOD program. I have the phone set up and working, but I only have a 3g signal when I should have 4G LTE. Sprint has LTE coverage in my area, and I have seen 4g LTE pop up briefly when I was first setting the phone up, but it was short lived and won't go back to it, only 3G.

Comments

  • M.A. II LopezM.A. II Lopez Posts: 1,163FreedomPop Master, FreedomPop Expert ✭✭✭
    @Christian Mattison‌ it could be you don't have a static 4glte signal were you are. I had the same problem with my service on that device and according to the apparently useless Sprint coverage map I should have been swimming in 4glte on my I95/I10 32207 area of Jacksonville Florida. Try going around your neighborhood to see if being outside makes a difference. Remember when you are in WiFi range the 4glte will revert to WiFi on FreedomPop.
  • Jose PerezJose Perez Posts: 0FreedomPop Newbie
    For me it switches dramatically fast from 4g to 3g even if am only a couple of blocks away from home I get 4g even in the same town.
  • Christian MattisonChristian Mattison Posts: 1FreedomPop Newbie
    Well my issue is this: When I do a factory reset (which I have now done several times trying to get this to work) I get a strong 4g LTE signal, the phone activates, does updates, reboots to strong (4/6 bars) 4G LTE and after a few minutes it drops to a weak (1/2 bars) 3g and stays there. Everywhere I go it's 3g. On top of that, I start off with great call quality, and after less than a day it goes to crap. I'm at a loss on what to do. Update profile....update PRL....update and restart freedompop messaging....reboot the phone....round and round. This is getting frustrating. My mom bought a GS3 for BYOD just like I did (cheaper than buying directly from freedompop) and her phone works just fine. Clear calls and 4g LTE, no issues.
  • Abbey HAbbey H Posts: 0FreedomPop Newbie
    @Christian Mattison, your GS4 has a removable SIM card (ICCID#) inserted in your phone, right? Just checking.... I have a different device (Galaxy Tab 3) which also has a SIM card slot (required for 4G LTE, but not for 3G), and when I activate (via BYOD, and then activate Tab 3 itself), I do see 4G LTE during the hands-free activation, but as soon as hands-free activation is over, it drops to 3G only, and also I get error messages telling me something like "Network was not detected, please restart" etc. every 30 min or so, so I just ended up removing my SIM card to avoid these "restart" messages popping up and live with 3G only. Not sure if your GS4 is getting these SIM card error messages, but the fact that you see 4G LTE during activation, but after that it drops to 3G sounds like a similar problem I'm having with my Galaxy Tab 3.

    Sprint's GS3, I believe, has an embedded SIM (not removable). That could be one of the possible reasons that GS3 is working fine with 4G LTE for her. Just my wild guess...
  • Christian MattisonChristian Mattison Posts: 1FreedomPop Newbie
    Yes it has a SIM, and the GS3 does also, so that's not the issue. I have discovered that I can get a 4G LTE signal in some places, but it's spotty at best. I've tried calling Sprint and they say I have a very weak signal (25% or so). OK, fine....nothing I can do about that. And that jives with the signal strength I see on my phone. I can't help but wonder if dropping the Sprint SIM and getting a Ting SIM might help. At this point I'm not really concerned about the 4G LTE anymore, I've seen it at 4G when I'm out and about, and I'm convinced that Sprints coverage map is just misrepresenting their actual coverage. My biggest issue at this point is call quality. Even on wifi it's constantly breaking up. I need to use my phone for personal and business calls and I can't have my customers unable to hear me. My mom has also complained about calls breaking up even when she has a strong LTE signal. Not really sure what to do at this point.
  • Eugene FullingtonEugene Fullington Posts: 1FreedomPop Newbie
    I am also having this issue. I have an LG G3, 4 bars on data strength and strong wifi.
Sign In or Register to comment.