Due to our current migration process, some of our operations will be temporarily unavailable in order to make the transition seamless. One of those being our ability to swap devices. Rest assured as we are working diligently to resume all operations for a better overall experience.

However, as we understand the excitement of waiting on pending situations, we still offer customers the ability to BYOD (bring your own device) in order to expedite the use of the desired device. Feel free to find out more by visiting the following link:

Thank you for your patience and understanding throughout this process.

Reactivate inactive account/device

Fredrick_BassFredrick_Bass Posts: 3FreedomPop Newbie
I had a device on my account and let it go dormant. I did not realize it had been that long as we had moved and the device was sitting at my desk in a box. I tried calling support but was transferred many times. I called 800-671-5017. After waiting on hold I was transferred to tech support. Tech support transferred me to sales. Sales transferred me to activation. Activation said they needed my phone number for the account but I do not know it. The FP app will not open. I only get an error that says please connect to the internet.

I do not have a mobile data connection so I also tried WiFi to no avail. The error is "oops there was an error trying to communicate with the server. Please try again later." The app will not open.

The drop down notification only says "Locating user for device" but never goes anywhere.

Online account says I have no devices, but this device was previously on my account.

IMEI is 990005467192643

I tried uninstalling and reinstalling the FP app. I restarted the device. verified the APN.

Online activation says the device is already activated.


  • [Deleted User][Deleted User] Posts: 0 admin
    The user and all related content has been deleted.
  • Fredrick_BassFredrick_Bass Posts: 3FreedomPop Newbie
    Thank you for your help!
    The MEID would be the number above without the 3 at the very end. I had the same issue trying to find the correct info.

    I am certain the device in question is one of the 2 you found. I ordered a SIM but was never able to use it. I then purchased a device, Moto e LTE and was able to use your service. The Motorola e would be the device I am trying to use. The other 1 (or 2, I think) SIM cards that were on my account were never useful to me as I never had a device capable of using them.
  • [Deleted User][Deleted User] Posts: 0 admin
    The user and all related content has been deleted.
Sign In or Register to comment.