**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

Moving from iPhone 6 to XR but, ran into problems — no cell/mobile now

pointpoint Posts: 16FreedomPop Newbie
This seems like it should be simple. I have an iPhone 6 which I got from FreedomPop. So it came with a Sprint network SIM in it.
I recently got an unlocked XR. A FP rep told me the old card was no good. I would need to get a new one. Then transfer the number over. But when I was being helped by the Apple Store rep, he said, I could just use the old card. I tried that but, it did not work at all. So I bought a FP SIM from BestBuy. It says compatible with iOS GSM devices 4G LTE. I put it in the XR and, maybe my memory is wrong but, I thought I tested it in a call to my land line and it worked. I get bars and it is “registered”. But not long after, it now does not work. Bars, registering still yes.
It says there is an i/o error.
FP customer service is so slow to respond and, I kind of need this phone to work.
It can't be that strange of a situation going from iOS on a 6 to iOS on an XR. What can I do to make this phone work?

Comments

  • EuniceLEuniceL Posts: 383 admin
    point said:

    This seems like it should be simple. I have an iPhone 6 which I got from FreedomPop. So it came with a Sprint network SIM in it.
    I recently got an unlocked XR. A FP rep told me the old card was no good. I would need to get a new one. Then transfer the number over. But when I was being helped by the Apple Store rep, he said, I could just use the old card. I tried that but, it did not work at all. So I bought a FP SIM from BestBuy. It says compatible with iOS GSM devices 4G LTE. I put it in the XR and, maybe my memory is wrong but, I thought I tested it in a call to my land line and it worked. I get bars and it is “registered”. But not long after, it now does not work. Bars, registering still yes.
    It says there is an i/o error.
    FP customer service is so slow to respond and, I kind of need this phone to work.
    It can't be that strange of a situation going from iOS on a 6 to iOS on an XR. What can I do to make this phone work?

    Hello, @point. Our support team will gladly assist you to resolve this issue. We will be opening a private message regarding this matter as we need to provide and gather personal account information.
Sign In or Register to comment.