8 Days 'Processing' Order?

Keith JKeith J Posts: 40FreedomPop Newbie
Hello. I ordered an Alcatel One Touch Conquest on July 1st. When I look at my account for that phone it reads "Processing - Your order is currently being processed". Shouldn't it have been shipped by now?
I tried to upload a screen shot but, for some reason, I am unable to - the upload buttons are not working for me.
I never received an order number by email - only a phone number confirmation.

Answers

  • Rich Sias (16th)Rich Sias (16th) Posts: 3,282FreedomPop Newbie, FreedomPop Master, FreedomPop Expert ✭✭✭✭✭
    @Keith J - Do you have an email from them with subj: Welcome to FreedomPop! ? It has your password in it. Plus a link to log in direct to your online account. Use email as ID and the password to login here: https://my.freedompop.com
    You will only see the shipping status before the truck picks up the package. There are like 5 stages of shipping. The first one or two take like F O R E V E R, then the last three seem to be zippy do da and it's out the door. Then you see the overview of your account and you can explore everything.
    Be my Valentine ZTE, Victory, LG Volt, 803S, & 4 SIMs
  • Keith JKeith J Posts: 40FreedomPop Newbie
    Hi Rich and thank you for replying. :smiley: Shipping status actually moved up to "Preparing Shipment
    Your device/SIM is being boxed up for the journey to your doorstep!", a couple of days ago. Still no shipping email though.
    When I ordered my 1st phone through FP a couple of years ago I never received an email stating it was shipped or a tracking number (and the shipping status never updated). Suddenly the phone just arrived.
    Unfortunately I hadn't heard about the transfer of the company before I submitted the order. Now I will have two FP phones on Ting - not pleased with that. :neutral: I hope Red Pocket steps up and makes it easy for us CDMA folk to transfer to them.
Sign In or Register to comment.