Netgear Unite Aircard--missing battery, "SIM failure"

dexterhughesdexterhughes Posts: 3FreedomPop Newbie
I received my FreedomPop Unite hotspot (an Aircord 770S) a few days ago; it came with the SIM I had also ordered from FreedomPop, so I expected everything should have been activated. However, there are two problems I'm unable to solve despite following all the getting-started instructions I could find:

1. The device appears to have no battery.
2. I am unable to connect to broadband after updating the APN settings; I continually get the error, "SIM failure. Please ensure you are using a SIM provided by your network provider." I've removed and re-installed the SIM card a couple times to no avail.

Can someone assist me with these two problems? Thank you!

Answers

  • Rich Sias (16th)Rich Sias (16th) Posts: 3,344FreedomPop Newbie, FreedomPop Master, FreedomPop Expert ✭✭✭✭✭
    edited August 15 #2
    @dexterhughes
    1. Pop open the back and remove the useless battery. Plug in the charger with battery gone and try to power on. If your's works then all you need is to replace the battery. FreedomPop will replace the battery but may take a while. I suggest you order one with IDENTICAL text as on yours from eBay. Shipped from US will be faster and maybe a bit more than from China (4-7 weeks)

    2. Did your Unite arrive with a SIM already installed in it ? If you have ordered an LTE SIM with calling & texting included then likely not work for you in the Unite. I tried on mine and could not get my Voice-Text-Data SIMs to work in the Unite. The data-only SIM that is supposed to be already in the Unite should work fine.
    Be my Valentine ZTE, Victory, LG Volt, 803S, & 4 SIMs
  • dexterhughesdexterhughes Posts: 3FreedomPop Newbie
    Thanks for responding, @Rich Sias (16th). Unfortunately the problems I'm having are a little more severe! First, it's not that the battery is useless; it's that there simply is no battery. The device does power on when plugged in--but a battery seems rather crucial; I have no way of knowing what the exact specs are for a replacement.

    Second, we ordered the data-only SIM; it is in the device but I'm having a hard time getting it to work. When I log in to my account management screen, I see a green box telling me to take some steps to activate the SIM; but when I click that link, I'm told "congratulations, your SIM is activated." But the device itself continually shows the "SIM failure" message.
  • Rich Sias (16th)Rich Sias (16th) Posts: 3,344FreedomPop Newbie, FreedomPop Master, FreedomPop Expert ✭✭✭✭✭
    @dexterhughes - I took as photo of my battery and the photo poster pull down doesn't react for me. Here is the text info from my battery.
    LITHIUM ION BATTERY
    Model No: W05
    Voltage: 3.7v 9.25Wh
    Min capacity: 2500mAh
    P/N 5200031 [ White box ]
    Sierra Wireless [ Bar code ]
    Made in China [ Bar C Number ]
    Red outlined box with warnings.

    I searched on Google shopping "Netgear W-5 battery"
    Or in eBay. Lowest NEW price in eBay was $8.50 arrive in 4 business days (Aug 22)
    Do not order any until that SIM is working first.

    I tried inserting my SIM in backwards or upside down and it would not click in fully. Only when put in proper with cut corner in first would it click in fully. You likely have inserted it in properly. Examine the plain NON gold side first half of the ICCID starting with 890 then a blue circle with a white FP side ways in it. Last is second half of the ICCID. Both the Voice-Text-Data SIM and the data-only SIM appear the same visually.
    .
    I tried my VTD SIM and it appears to work ! It wasn't working, 4 months ago when I first got my Netgear Unite. So, if you have a normal SIM, you can try that if you kept the outer rectangular rings from the 3 in 1 kit. You'll need them to convert back to the bigger mini SIM size.
    Be my Valentine ZTE, Victory, LG Volt, 803S, & 4 SIMs
Sign In or Register to comment.