Galaxy S3 no LTE

AJ WertmanAJ Wertman Posts: 1FreedomPop Newbie
Hi, I have activated my old Galaxy S3 using the BYOD service, and calling works fine, I did not test texting yet, but I only get 3G data. When I had Virgin Mobile, I got LTE at my house and around my area, on the FreedomPop coverage map, it says my house/area has LTE, but my phone won't connect. I made sure LTE mode was on, I tried updating the PRL, Profile, and Firmware, nothing worked. Once I got the error, "Unable to establish wireless data connection" With the message "EHRPD:5", but I have not seen it since. How can I get LTE?

Comments

  • Ali Ali Posts: 6,705FreedomPop Master, Test Role, iOS Master ✭✭✭✭✭
    This looks like a SIM card issue, did you try to get a new one?

    You can try one from Ting for $9, make sure to get the correct one for your phone.
  • AJ WertmanAJ Wertman Posts: 1FreedomPop Newbie
    My phone does not have a user accessible spot for me to put a new sim card in. There is nothing under the battery, and there is just a micro sd slot under the back cover.
  • Richard AllenRichard Allen Posts: 644FreedomPop Newbie, FreedomPop Expert, Porting Master ✭✭✭✭
    @Aj Wertman Did you check the Sprint coverage map for where you live to see if they list the signal strength as"fair"? I live in a location that Sprint lists the signal strength as "fair". At home I cannot get an LTE signal. I have to walk 2 blocks down the street before my phone will pick up a very weak 4G LTE signal. I do not feel the Sprint coverage maps are very accurate for 4g LTE.
  • AJ WertmanAJ Wertman Posts: 1FreedomPop Newbie
    @Richard Allen‌ The Sprint coverage map shows my whole area as "Best" for LTE. I am in the Allentown PA area. My friend has Sprint, and she gets LTE almost everywhere around this area.
Sign In or Register to comment.