MiFi 500 Will Not Connect to LTE

David AlterDavid Alter Posts: 2FreedomPop Newbie
I'm having a problem getting my MiFi 500 to connect to the LTE network. I've tried changing the settings on the device to "LTE Preferred" as well as "LTE only" and no luck.

It is definitely not an issue with the Sprint coverage or towers in my area since I've been trying for 2 months in various large cities to get this to connect (Chicago, Denver, LA, San Diego, Las Vegas, Dallas, no go...)

I've also tried updating the PRL and profile on the device and received the following errors:

"There were errors while updating the profile."
"No PRL update available"

Has anyone had this problem with the MiFi 500? I'm guessing there is an account/profile setting that is incorrect...

Comments

  • Ali Ali Posts: 6,705FreedomPop Master, Test Role, iOS Master ✭✭✭✭✭
    You may need an account refresh, contact an admin to get that done. Afterwards do the PRL and Profile update again and then you should be good to go.
  • Matthew GunterMatthew Gunter Posts: 32FreedomPop Newbie
    Mine required a new SIM, but even after that I needed to do a full modem reset (hands free activation) for it to work. If you have the new firmware on your device you will need the MSL code for that (FP can get it).
  • werler321werler321 Posts: 11FreedomPop Newbie
    Hello all. I have this exact same issue as reported by David Alter. How do I contact an admin for an account refresh? Any help would be greatly appreciated.
  • C YEHC YEH Posts: 9FreedomPop Newbie
    Same issue for me. Tried LTE only and preferred but no luck. I've even put in a new SIM card. How can I get request an account refresh with the new SIM card? Thank you
Sign In or Register to comment.