**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

Cannot make calls or messages

When I try to phone, asks for account email address. Does not accept the correct email address - I receive the followin error: freedompop account error: the server encountered an error while processsing your request. Please try again later. If you continue to have trouble please call 888-915-2647.

Have been using the phone since around 1st of July.

Also, when I log into my FreedomPop account, asks me to activate a new device.

Tried to reactivate my phone, but says please enter a vaild MAC Id. I am entering 256691486703605877

I purchased this phone thru FreedomPop. It is a Samsung Victory 4G LTE .

Thank you,
Mebelile

Comments

  • @Mebelile‌ It looks like the payment method is missing from your account. FreedomPop requires that all customers have a valid form of payment on file, even if they are on the free plan in order to enjoy service. Please add this to your account in order to reactivate. Thanks and have a great day!
  • MebelileMebelile Posts: 0FreedomPop Newbie
    Jasmines,

    I have input valid form of payment on my account. When will service be reactivated?

    Thank you,
    Mebelile

  • Rich Sias (16th)Rich Sias (16th) Posts: 3,124FreedomPop Newbie, FreedomPop Master, FreedomPop Expert ✭✭✭✭✭
    @Mebelile‌ log in to freedompop.com with your account.
    While you wait.
    If red banner still there, wait an hour, check again, rinse and repeat.
    When red banner gone, you're good to go.
    Be my Valentine ZTE, Victory, LG Volt, 803S, & 4 SIMs
  • MebelileMebelile Posts: 0FreedomPop Newbie
    When I log in there is not a red banner. After logging into account it is asking if I have a device. Tried to go into usage services, overview receive message: Whoa, you can't do that…
    you haven't tried our Free High Speed Internet yet.

    Tried to go into Services and Plans and received error: HTTP Status 500 -

    Please help,
    mebelile
  • Hi @Mebelile‌

    I just sent you a message with the email that is associated with your account. Just wanted to confirm that you are using that email to log in :)
  • MebelileMebelile Posts: 0FreedomPop Newbie
    KathyFP, Please resend the email - I have not received it. This is my email.
  • MebelileMebelile Posts: 0FreedomPop Newbie
    Thank You! Everything is now working! Thank you for your patience and knowledge.
    Mebelile
  • @Mebelile‌ Excellent! We are very happy to hear that everything has been resolved for you. Enjoy your Tuesday as well as the rest of your week.
Sign In or Register to comment.