Your call can't be completed because you are out of minutes

Robert GlassmyerRobert Glassmyer Posts: 5FreedomPop Newbie
First time poster, but I wanted to share with the other folks who are having problems with this issue. I got my son an Evo 4g to activate under the byod option. Everything worked flawlessly for the first week, then we discovered he couldn't make calls getting the "Your call can't be completed because you are out of minutes" message, even though he has the unlimited talk and text plan. I spend several hours here following suggestions, update prl, profile, ##786# reset with no luck and contacted tech support (20 minute hold) which was escalated and I was told I'd receive a call back within the next 48 hours. I couldn't even post here yesterday, the "new discussion" button wasn't showing up on the forum pages for whatever reason, very very frustrating ><. I finally looked to other sprint support pages and found a tech forum where they said in no uncertain terms to make SURE all wifi was turned off when reseting and updating the prl and profile or it would fail but display a completion message in most cases. Every time I reset I immediately put the phone back on my home wifi because it only had the 500mb free data service and I tried to conserve it. I turned wifi off, reupdated the prl and profile and it finally worked again. And any other Evo users out there, if you fail to find the reset option when you dial ##786#, hid the menu button from the reverse logistics screen, it's there, just hidden.

Hope this helps someone!
Sign In or Register to comment.