**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

System Requirements: What do I need to be able to use the Bolt with my computer or tablet?

[Deleted User][Deleted User] Posts: 31
edited December 2013 in Freedom Stick Bolt (4G) #1
Here are the minimum requirements for our Bolt USB stick:

- An activated account and service with FreedomPop.
- A device with a standard USB port.
- One of these operating systems: Windows XP (service pack 3), Windows Vista, Windows 7, WIndows 8, Mac OS 10.5 Leopard, 10.7 Lion
- It is also compatible with devices that have: Linux, Android, and Chrome versions that support Remote Network Driver Interface Specification (RNDIS) or Communication Device Class (CDC) devices.
Post edited by FreedomPop on

Comments

  • Some users have also been really successful with connecting their Bolts to cradle points, but it requires some extra research and work.
  • bobfields57bobfields57 Posts: 1FreedomPop Newbie
    Has anyone tried this Stick on Linux Mint?
This discussion has been closed.