FreedomPop Sprint U600 not working

Philip BarrettPhilip Barrett Posts: 4FreedomPop Newbie
edited February 2015 in Using Your Devices #1
Hi!
I attempted to use my U600 tonight and it did not work. I see the device on my account, but it seems like there is no 3G on my account or something. The MEID (Mac Address) is (For security reason, please post the esn/meid in a Private message to a qualified Freedompop member) and the email used on my account is [email protected]

Thanks
Phil
Post edited by njfulwider5 on

Comments

  • Ali Ali Posts: 6,735FreedomPop Master, Test Role, iOS Master ✭✭✭✭✭
    @Philip Barrett‌ Are you on a 3G Plan? The Free plan includes 4G WiMAX only.
  • Brian McPhersonBrian McPherson Posts: 1,365FreedomPop Newbie, FreedomPop Master, FreedomPop Expert ✭✭✭✭
    To add to Ali responds is the the lowest pay plan for 3g is $3.99 a month for 500mb of data.
    Email: [email protected]
    [email protected]

    For better help in real time, "Skype" is the best help I can offer. My Skype User is "freewill95". You can add me to your contact list and in the message box, type "freedompop user".
  • Philip BarrettPhilip Barrett Posts: 4FreedomPop Newbie
    I was not aware of that. It seams like when I first got it I was able to use 3G on the free plan as well, has that changed?
  • Ali Ali Posts: 6,735FreedomPop Master, Test Role, iOS Master ✭✭✭✭✭
    @Philip Barrett‌ Sprint Smartview gives an error 777 if you're not on a 3G plan and you attempt to connect. It costs $3.99 monthly, I wouldn't think its too bad :)
Sign In or Register to comment.