Why Won't My New Phone Power On?

Ian R TitusIan R Titus Posts: 0FreedomPop Newbie
Greetings,

Apologies if this has already been discussed elsewhere, but I could not find an answer to this specific issue in my search through previous discussions.

I'm a new member to FreedomPop and I received my Samsung Galaxy S3 a week or so ago. I proceeded to charge the phone and when I connected the charger the screen lit on as did a red light on the phone. Because I had decided to port my old cell phone number instead of using the new one I was given, I was waiting for confirmation before I used the phone at all. When the confirmation came through I went to activate the phone but I could not power it on. When I pressed the ON button all I would feel is a vibration or two but the screen would remain blank.

I tried several suggestions I found online, including removing and replacing the battery, pressing the ON, Volume and Home buttons simultaneously, and others with no luck. The only thing that did happen is that briefly a battery icon appeared, along with the SAMSUNG logo but the screen returned to black. It seems that the battery is fried or that the charger is defective? My first free month is basically done and I haven't been able to use the phone at all. Can I take it to a Sprint store to verify what is wrong or do I have to send it back to get a replacement? If it's the latter, what address do I send it to? Any help with this is greatly appreciated. Thank you.


Best Answers

Answers

  • Ian R TitusIan R Titus Posts: 0FreedomPop Newbie
    Thank you very much for the reply. I did buy the phone directly from FreedomPop. I tried your suggestion several times but it didn't work. How do I go about getting a replacement?
Sign In or Register to comment.