**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

My wife bought Galaxy Victory phone from Freedompop, has issues making/receiving calls

Text messaging works fine, but when trying to make a call, after the number is punched in via the keypad, the display dialed number field goes black, and the call is not made. Also, she is not receiving calls. I have tried all the tips on the Freedompop FAQ page, but no improvement.

Answers

  • Ali Ali Posts: 6,735FreedomPop Master, Test Role, iOS Master ✭✭✭✭✭
    Have you tried to force clear and restart the Messaging app?
  • bondmanpbondmanp Posts: 5FreedomPop Newbie
    I called Freedompop, and I was walked through that process, as well as uninstalling and reinstalling the Freedompop Messaging app. It help a little, but calling is still spotty, with several dialing attempts needed to get a call through without the phone just being unresponsive to attempts at dialing a phone number. Then, the latency is so big that that the other party will hang up before they hear me. I tested this by calling my home phone from my home. It was a good 5-seconds between the home phone being picked up and when my voice from the Freedompop phone was able to be heard. Also, the green answer icon was not functional. I had to tap the menu option and tap "answer call" in order to pick up an incoming call. Interestingly, this is my wife's phone, and I have an identical Freedompop Galaxy Victory phone with none of these issues. My wife is convinced the phone is messed up, and I am beginning to agree with her. What are my options for exchanging this phone? We've had it a few months.
  • Robin HardisonRobin Hardison Posts: 18FreedomPop Newbie
    bondmanp said:

    What are my options for exchanging this phone? We've had it a few months.

    So it has been working fine for a few months until now?

    Have you a tried a complete reset/restore of the device?

Sign In or Register to comment.