**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

Phone function constantly stops working.

Simeon WaltonSimeon Walton Posts: 28FreedomPop Newbie
This is something that happens quite often with this phone. I will get a call from someone one my home or work phone or someone will send me a text telling me that they are trying to call but I don't answer. The truth is the phone didn't ring. When I go to investigate the issue, I find I can no longer call out. Then I go through the motions of reconfiguring FP and restarting the phone, which usually works, except for this last time. There was an update pushed out a couple of days ago and when it installed the phone stopped working. I tried doing what I always do, reconfigure FP, yada, yada, and this time I actually had to uninstall the update to get the phone function to work again. I have to say, this is a great little computer but the phone function sucks. Unfortunately, it was the only phone that FP offered when I signed up 6 months ago. The phone function has stopped working more than a dozen times. I asked for a new phone but that went on def ears. If anyone has any ideas on how to stop this from happening I would be eternally grateful. Has worked now for about three days, fingers crossed.

Comments

  • djinksdjinks Posts: 1,270FreedomPop Newbie, FreedomPop Expert ✭✭✭✭
    @Simeon Walton
    Is this a FreedomPop branded phone? Have you uninstalled and reinstalled the phone app? You can also try going to Settings->More->Application Manager then find the Freedom Pop phone app and Force Stop and Clear Cache. If you clear data you will need to reconfigure the app so avoid that.
  • Simeon WaltonSimeon Walton Posts: 28FreedomPop Newbie
    djinks, this is a FreedomPop branded phone and they do not allow their installed programs to be uninstalled. No button for that. That is the big problem, I find my self going through the motions of clearing cash, forcing stop and reconfiguring and I am just tired of it. I shouldn't have to keep doing this over and over again. It stopped working again today. Such a pain.
  • LaurensphoneLaurensphone Posts: 4FreedomPop Newbie
    Having the same problems since last August. I spend hours on it every couple of weeks just hoping it will be updated to a point where I can use it. I only paid $80 for the phone, but that's $80 I would have preferred to have kept.
  • Simeon WaltonSimeon Walton Posts: 28FreedomPop Newbie
    Thanks Lauren. That helps to validate my claim. I've had a pretty good couple of weeks now without any problems. I did however have to uninstall the last Messaging App upgrade, but I have to say, it's been working ever since.
    I have a feeling that FreedomPop does not put enough effort into comprehensive testing before they release their updates. It seems pretty obvious to me. I think that Samsung could have done better job to integrate the phone's memory and the SD card. Why is it that something so simple is so often overlooked?
Sign In or Register to comment.