**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

battery not charging

Kishore Kumar MareddyKishore Kumar Mareddy Posts: 1FreedomPop Newbie
I got ZTE force new one. my battery is not charging until I reboot the device. any help?

Comments

  • RossRoss Posts: 56FreedomPop Newbie
    my battery does the same.not every time but most of the time.i know its not the phone.
  • RossRoss Posts: 56FreedomPop Newbie
    my battery does the same.not every time but most of the time.i know its not the phone.
  • stefett2stefett2 Posts: 18FreedomPop Newbie
    I have the same issue with both of my ZTE Force phones. They will not start charging until I reboot the phone. I have tried multiple charges with the same results. The chargers work as expected on my HTC EVO 4G so believe it is the phones.
  • Peter WarnerPeter Warner Posts: 2FreedomPop Newbie
    I've had my zte force for about a month. This morning, the phone wouldn't come on. Plugging into the charger didn't work. So I took out the battery and plugged into the charger. Then the phone turned on. I put the battery back in. Even though the battery had been fully charged last evening, it showed 0% charged. It's now recharging. We'll see if it holds the charge.
  • Jorge Jorge Posts: 3,376 admin
    @Peter Warner Hello Peter, I apologize for the issues you are currently experiencing, if you could please PM me a picture of your batteries OEM number I will be glad to further investigate this issue.
  • njfulwider5njfulwider5 Posts: 10,413FreedomPop Newbie, FreedomPop Master, Test Role, FreedomPop Expert, FreedomFan, Android Master , FP Flyer ✭✭✭✭✭
    edited March 2015 #7
    hey guys....Just a quick Tip. Try using a different plug, if available? Make sure it is 5v 850ma or bigger

    let me know if you need more info on the plug
    Post edited by njfulwider5 on

    Great Tips and Trick, User Guides and How to's in my Signature-(Take a Peek)

    Hope you find any post I have created helpful. Please look for my How to-s(Downgrading-100% Free) and (How to use the FreedomPop Community), or my Guides on FreedomPop Devices(Phones) and (Hotspots). Here is one on (FreedomPop Plans). Here is one on all (FreedomPop Apps). He is one on(Traveling with your GSM Global Sim?) or Common Question about the (GSM Global Sim). You can PM me anytime by clicking this link here njfulwider5. Than click the BUTTON with the (Small Envelope), to left of the word (MESSAGE). I will do my best help. Welcome to FreedomPop

  • grac4grac4 Posts: 14FreedomPop Newbie
    Mine has issues as well, seems to charge when the phone is off but not when it is on. Multiple issues with my ZTE Force. There is sadly no way I can rely on this as a service :anguished:
  • Robert ConnorRobert Connor Posts: 76FreedomPop Newbie
    I had same problem as you. I think you probably need to update your Android OS (Operating System) to fix your battery issues. Please check @njfulwider5's post here on ZTE Force phones where you can follow the instructions on how to update the OS. Good luck!
  • khondamir yuldashkhondamir yuldash Posts: 2FreedomPop Newbie
    I have same issue. It looks like battery issue. I tried second battery and its charging. "Bad" battery won't charge on another device too.
Sign In or Register to comment.