NFC won't work on FreedomPop branded S3

Katherine HarvestKatherine Harvest Posts: 5FreedomPop Newbie
I recently activated a FreedomPop branded S3 and have noticed that the phone's NFC function doesn't work. The phone seems to think it's working -- I can switch NFC on in the settings without issue and when I check the logcat, no weird error messages show up... But it doesn't detect it if I hold a tag up to the back of the phone and it won't talk to my Nexus 7 for Android Beam purposes.

I did some research and found out with the S3, the NFC antenna is actually physically located on the back of the battery... So I peeled away a good portion of the paper cover on the side of the battery that faces the back of the phone, and there doesn't appear to be an antenna there.

Is it possible FreedomPop shipped my phone out with a cheap knockoff battery that doesn't have the NFC antenna? Can anyone else who's running a FreedomPop branded S3 (i.e. not a Sprint branded S3 activated through the BYOD function) and who's personally actually tried to use the NFC function with the battery you were shipped with your device comment and let me know if it worked for you?

The impression I get is that if I were to just buy another battery off of eBay or Amazon I'd essentially be taking a crapshoot as to whether or not the battery I get will have the NFC antenna. I've found numerous posts all over the net from people saying that many aftermarket batteries that purport themselves to support NFC turn out not to. Does anyone have any recommendations as to how I might go about avoiding a long, agonizing sequence of battery purchases and returns and just... Get one that works the first time around?

Thank you!
Kick away the pigeons / Dripping day glow sidewalks / They stole my bag of horse-hairs / While I was painting a toothy woodchuck

Comments

  • Sprinter GS3Sprinter GS3 Posts: 6FreedomPop Newbie
    I have a FP S3 and tried holding a NFC tag to the back after reading your post. Nothing happen either. I download the app NFC TagWriter by NXP and again held the Tag to the back and it was able to read it.

    I have not used NFC at all. . .so don't know what this means, Software issue maybe?

    My battery looks like the original Sansung.
  • Ali Ali Posts: 6,735FreedomPop Master, Test Role, iOS Master ✭✭✭✭✭
    @Katherine Harvest This is actually an issue with the FreedomPop ROM however if your NFC chip isn't there, I would suggest ordering an OEM replacement from FreedomPop directly.
  • njfulwider5njfulwider5 Posts: 10,413FreedomPop Newbie, FreedomPop Master, Test Role, FreedomPop Expert, FreedomFan, Android Master , FP Flyer ✭✭✭✭✭
    Please check the battery and make sure it is a NFC battery...inorder for the NFC to work on a S3, the battery has to be compliant...check your battery...I had to replace on of them in My other Freedompop branded S3 for it to work

    Great Tips and Trick, User Guides and How to's in my Signature-(Take a Peek)

    Hope you find any post I have created helpful. Please look for my How to-s(Downgrading-100% Free) and (How to use the FreedomPop Community), or my Guides on FreedomPop Devices(Phones) and (Hotspots). Here is one on (FreedomPop Plans). Here is one on all (FreedomPop Apps). He is one on(Traveling with your GSM Global Sim?) or Common Question about the (GSM Global Sim). You can PM me anytime by clicking this link here njfulwider5. Than click the BUTTON with the (Small Envelope), to left of the word (MESSAGE). I will do my best help. Welcome to FreedomPop

Sign In or Register to comment.