Tips and Tricks with the new FreedomPop Messaging app for Android! (16.01.101.0327)

Ali Ali Posts: 6,705FreedomPop Master, Test Role, iOS Master ✭✭✭✭✭
In this guide, I will share some tips with the new Android messaging app version 16.01.101.0327 that I found to make your calls sound much better and clearer.

This helps especially when on a 3G connection where your speeds are not as fast to support a VoIP connection but you need to make that call.

In my experience with doing the following, I was able to achieve call quality that sounded exactly like a standard phone but much clearer while on 1 bar of 3G.

To start with, let's enable some codecs and some settings under Audio to make your calls sound much better.

1. To the left of the blue speech bubble in the app, press the three lines to open your options pane
2. Press Settings
3. Go to the Audio options
4. Make sure Echo Cancellation is turned on
5. Calibrate your Echo detector. It will play three beeps to detect how much your echo is.
6. Set your code bitrate limit to 128kbps
7. Under codecs, enable all the codecs that are not checked.

Under call, leave the settings untouched.

Under network, make sure Use WiFi only is unchecked, enable ICE is unchecked, and Use Random Ports is checked. Leave IPV6 and IPV4 unchecked, and Push Notifications are checked.

Now when you make a call, it should sound much more clearer and easier to hear.

Comments

  • Ali Ali Posts: 6,705FreedomPop Master, Test Role, iOS Master ✭✭✭✭✭
    EDIT: Make sure that Enable UPNP is checked, and UNCHECK "Use Random Ports", and set the port to 5060. Thanks @Lawrence Reiss :)
  • LongmooseLongmoose Posts: 14FreedomPop Newbie
    Can you explain why this improves quality? What is UPNP? Why port 5060? What is ICE?
  • Ali Ali Posts: 6,705FreedomPop Master, Test Role, iOS Master ✭✭✭✭✭
    @Longmoose UPNP is a call setting under networks that changes the process of how SIP calls are made. With FreedomPop this setting actually has calls ring a little better. Port 5060 is the standard port for SIP, using random ones can result in different ports being used that are more likely to be blocked by your local network. ICE is there if your SIP provider requires it for how calls are connected however FreedomPop doesn't work with ICE being enabled.
  • Justin SarafinJustin Sarafin Posts: 1FreedomPop Newbie
    I tried the suggested settings and couldn't make or take any calls. When I changed the CODEC BITRATE LIMIT to just OPUS, 48000hz, I was able to make calls. I don't know if this is randomness or causation.

    I have the LG VIPER. Is there an ideal setting for this phone?
    AUDIO
    CALL
    NETWORK
  • johnmjohnm Posts: 99FreedomPop Newbie
    I tried those settings Ali, couldn't make or place calls either. Uninstalled and reinstalled
  • Carl FalconeCarl Falcone Posts: 46FreedomPop Newbie
    I made those changed to my Samsung Victory. Will see how it goes. So far I can make calls.
  • Carl FalconeCarl Falcone Posts: 46FreedomPop Newbie
    Nope, calls are choppy and sound far away
  • jandersonjanderson Posts: 12FreedomPop Newbie
    I just tested these setting and the phone doesn't ring when port 5060 is selected. When I checked use random ports it rings again when there incoming call. This when Wifi is on (I have xfinity - not sure if that is relevant - galaxy s3 - latest version of the app)
  • jandersonjanderson Posts: 12FreedomPop Newbie
    my calls cut in and out too. What happened to the media settings / clock-rate. there was an option before to set the app to expert mode to access these setting, but they are no longer available since I updated the app.
    When I check to echo canceller calibration - it un-checks echo cancellation. Should this remain checked ?
  • 8977 Manning8977 Manning Posts: 50FreedomPop Newbie
    @Ali do you have any updates to this list of suggestions? Does anyone else?
  • Linda SimpsonLinda Simpson Posts: 3FreedomPop Newbie
    calls cut off, often no service, and I charge the phone 3x a day (Samsung S3)
  • 1stJohn Arkley1stJohn Arkley Posts: 392FreedomPop Newbie ✭✭✭
    This really needs updating to settings that work I'VE for a start, if I uncheck that I can't receive calls.
    Billing cycle starts ~ 1st of month
  • akatheswedeakatheswede Posts: 17FreedomPop Newbie
    @Ali I tried your suggestion and now the phone will not get or make calls. Samsung Galaxy S4 from freedompop. I have removed updates as I could not remove app and updated, then restarted still nothing. setting seem to have reset to previous setting but no calls. WiFi full and 3-4 bars of cell service. Any ideas on how to get voice calls back?
  • dlfullerdlfuller Posts: 5FreedomPop Newbie
    Please update or remove your recommendations Ali. Same results here as with others – calls stopped working! Uninstall, reinstall, and accept default settings to at least restore lousy voice calls.
  • PowerslavePAPowerslavePA Posts: 1FreedomPop Newbie
    Yeah, these settings cause complete incoming and outgoing call failures. This should be removed.
  • HarryHydroHarryHydro Posts: 1FreedomPop Newbie
    Hi: Thanks for all the help trying to resolve these voice-quality issues. I was wondering if anyone has tried calling themselves with another phone. This is what I've noticed:
    Immediately after I answer, the voice is perfect. I'm talking on the FP phone and listening on another. After probably 'one' second, it gets scratchy/broken-up audio. Now, while I'm still talking, I have a message button there on the screen. I click it. The audio clears up for a second. Then bad again. I'm sitting at a screen with the phone-icon blinking. I click that. It takes me back again and the audio clears up again. I keep going back and forth, each time it clears up for a second. I think this app is having problems with processor priority! This last time, the light went off my screen. I couldn't see anything! Eventually, it came back. Then off again. I had to hang up the other phone.. App needs an overhaul..
Sign In or Register to comment.