**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

Can't connec to 4G with U770

Mary SmithMary Smith Posts: 3FreedomPop Newbie
I've seen a few people post having issues connecting to 4G and mods updating something on their account to make it work so I hope this is the case for me too. I bought a U770 and the previous owner said he was able to connect to 4G in the same area I'm in but I can't for some reason. I was able to activate it just fine and I can actually connect to 3G even with the free 500MB plan, which I hope I don't get charged for. Can someone look into my account please? Thanks.

Comments

  • Ali Ali Posts: 6,735FreedomPop Master, Test Role, iOS Master ✭✭✭✭✭
    @Mary Smith You won't be charged for 3G access if you're on the free plan. However if 4G isn't working for you you may want to try a factory reset or using Sprint Smartview to see if your device can pick up 4G with that :)
  • Mary SmithMary Smith Posts: 3FreedomPop Newbie
    Thanks, Ali. I tried using a Sprint Smartview and it did not detect the device. As far as doing a factory reset, would you or anyone happen to know how to do it on the U770? I tried Googling it but nothing came up. Thanks.
  • Mary SmithMary Smith Posts: 3FreedomPop Newbie
    So I finally saw 4G Wimax for the first time. I had 3 bars but I can't connect to it for some reason. 3G also had 3 bars but I connected to that just fine. Any help would be great. Thanks.
  • DUDLEY BERTRAMDUDLEY BERTRAM Posts: 1FreedomPop Newbie
    I purchased a U770 and initially checked it out in Rochester NY where it worked fine. I could see 3G, 4G WiMAX and 4G LTE available networks. I verified that I could use the 4G LTE and get a decent connection. Checked the coverage map and it showed good LTE coverage in Tucson AZ. Sent the device to my daughter there. She currently has a freedom pop overdrive pro with the upgraded plan to use 3G in her area since no WiMAX. When she tried the U770 it shows no networks available of any type on the management page (I expected her to at least see 3G as an available network). Any suggestions ?
Sign In or Register to comment.