Slow data service

Clark LandryClark Landry Posts: 71FreedomPop Newbie
I have used up my 4G data and am on 3G... supposedly.

It is FEDERALLY MANDATED that 3G connection be a minimum of 200Kb/s. I am getting 60Kb/s every time I run a speedtest. I have a cell tower literally on top of the building I live in. I get more than 600Mb/s on 4G so I know it's not a connectivity issue; my connection progressively SLOWED to this speed over the course of a week. Something is being done which is artificially limiting my connection speed beyond what I was told it would be when I signed up. Please fix my service.


  • Ali Ali Posts: 6,735FreedomPop Master, Test Role, iOS Master ✭✭✭✭✭
    @Clark Landry Does this occur on a different cell site? Having a tower on top of your building doesn't improve service since cell towers send data out like a fountain, anything directly below it may be connected to a cell site 5 miles away!
  • Clark LandryClark Landry Posts: 71FreedomPop Newbie
    My speeds are capped at 60Kb/s no matter where I go.

    I called the telephone tech support yesterday and they were ridiculous - obviously the person wasn't listening to my problems and offering advice based on the symptoms but instead just reading off a script. She first suggested that I reset my phone by pulling the battery; I told her I had reset my phone many times already and that wasn't fixing it... that it must be the connection itself that was being limited. After a little while more she suggested that I factory reset my phone. Even WORSE idea... I'm not about to lose all my contacts and whatnot since I don't use synching services. I told her AGAIN that I am FULLY CAPABLE of getting decent speeds but the connection itself was being capped at 60Kb/s. It seemed like I was just being given solutions that would end the call.

    I was put on hold while my tech went to confer with someone about resetting my service. After a couple minutes the call dropped and I got a message on my phone that my service was reset - suddenly I was getting a 500Kb/s connection. Hours later I was back down to 60Kb/s once again.
  • Clark LandryClark Landry Posts: 71FreedomPop Newbie
    @Ali Any ideas? I would really like to be able to use my phone - as it stands I'm not very satisfied being with a service that gives me a lousy trickle of data and results in half the calls and texts I get not going through. It's been almost a whole month since I got it. The first week before I used up my 4G was fine, but since I've been on 3G this horrible service unacceptable. Am I going to at least get a refund? Are you guys even working to figure out the issue? I've missed over 40 calls and texts in the two weeks; a couple which were important interviews I've had to reschedule.
  • djinksdjinks Posts: 1,270FreedomPop Newbie, FreedomPop Expert ✭✭✭✭
    @Clark Landry
    What model device do you have?
    Is it Sprint or FreedomPop branded?
  • Clark LandryClark Landry Posts: 71FreedomPop Newbie
    @djinks I have the SPH-L720T. It's Sprint's "triband" version of the Samsung Galaxy S4. I know some other people who have this phone with FreedomPop and don't encounter any connectivity issues.
  • djinksdjinks Posts: 1,270FreedomPop Newbie, FreedomPop Expert ✭✭✭✭
    @Clark Landry
    That is strange. What happens if you switch to CDMA only in the Settings->Connections->More Networks?
    Do other Sprint or FreedomPop users in your same area experience this? 3G reception in my area is good. Is your device Sprint or FreedomPop -branded?
  • Clark LandryClark Landry Posts: 71FreedomPop Newbie
    I seem to have fine reception - my speed tests are the full 60Kb/s the whole time, after a brief half-second burst of a few Mb/s. It's obviously being throttled down to this speed.

    If I switch to CDMA only I get no connection whatsoever. No other users in my area have this issue.
  • djinksdjinks Posts: 1,270FreedomPop Newbie, FreedomPop Expert ✭✭✭✭
    @Clark Landry
    OK, so 3G is not working at all on your phone and you are getting the LTE throttling speed. I did not realize it was that low. Have you tried Update Profile and Update PRL?

    On Android 4+ use:
    Settings->More->System Updates->Update Profile
    Settings->More->System Updates->Update PRL

    If that does not work, try the SCRTN reset:
    (directions per @Ali)
    (Note: Back up your data as this can potentially erase your phone)
    (Note2: Make sure your phone is fully charged and plugged in before starting)

    1. Dial ##72786# in the native dialer and the SCRTN message should appear. Enter your MSL if needed (found by clicking here

    2. Your device will restart, proceed to unlock the device

    3. The Hands free reactivation will occur, its going to update your PRL and Profile. If it fails then update it manually Settings -> System Update -> PRL and Profile

    4. If you lost any data then please re install the My FreedomPop app and the FreedomPop Messaging app.

    This doesn't do resetting except for whatever is needed :)

    If that does not work or you have already tried it, you are going to need an admin's help.
  • Clark LandryClark Landry Posts: 71FreedomPop Newbie
    @djinks I did a manual PRL and profile update. Well, a few PRL updates... the button didn't gray out and I didn't get notices that there were no updates or anything so I don't know if the updates stack or replace. Should I have kept going? Something tells me the PRL updates weren't "sticking." There were no notable changes in speed aside from a few Kb/s up or down in each subsequent speed test between PRL updates. Standard deviation.

    Afterward I tried switching to CDMA only instead of LTE/CDMA and IT WORKED THIS TIME! I'm getting slightly better speeds - 80 Kb/s instead of 60 Kb/s - but that's still not adequate.

    I accidentally ended up monkeying with some other stuff as well, and... well... that's what ended up making the biggest difference so far. While still under CDMA-only mode I went into the messenger app and poked "refresh activation data" - my next speedtest was about double the previous one. Tried a PRL update while CDMA-only and was told there were no updates. Did a profile update and there were no changes in speed. It's still lousy speed and an order of magnitude slower than I was getting the first week I was on 3G, but at least I'm making progress.

    I get the feeling that I still need an admin, though. I didn't do a factory reset - I did one right off the bat when I was first having issues and it solved absolutely nothing. I've done network analysis professionally in the past; I know how flagged accounts work and am familiar with the characteristics of throttled connections. I don't have another FreedomPop device to test, but my g/f uses Virgin Mobile (which ALSO piggybacks on Sprint's network, like FreedomPop) and her 3G speed is almost 3Mb/s at all times at my place. She LOVES the reception here in fact. The irony is not lost on me.

    BTW I noticed that in the messenger app settings it said I have 2.48 MBs left. 9 remaining days. My plan is supposed to be the Unlimited Everything, so I don't know what's going on here. The billing section on the website seems to indicate everything is in order - is the messenger app just a little funky?
  • Clark LandryClark Landry Posts: 71FreedomPop Newbie
    @djinks Also, my speedtests on the CDMA-only setting all place my location in Kansas. I'm in Wisconsin... this was properly set on the LTE/CDMA/EVDO setting. I have location/GPS turned off so it's using the IP address to determine the location (I'm assuming).
  • Clark LandryClark Landry Posts: 71FreedomPop Newbie
    @djinks I just tried to text my phone from my computer. I'm not receiving them while in CDMA-only mode. Calls go through just fine. Also, my phone is updating the PRL every few minutes now... not only is it intrusive to whatever I'm doing to have the dialog box pop up, but this interrupts any active data streams. Been trying to watch a youtube video for like an hour now but it keeps breaking part way through and I'm forced to reload.

  • djinksdjinks Posts: 1,270FreedomPop Newbie, FreedomPop Expert ✭✭✭✭
    I cannot suggest anything else. Guess we need an admin to look at the account. I have sent a PM, but don't expect a response until Monday.
  • Clark LandryClark Landry Posts: 71FreedomPop Newbie
    @djinks Well now my "data left" row in my messaging app says 0 MB. 8 remaining days.

    Thanks for your suggestions... I'm glad I got a modest speed increase, but it sucks that I had to sacrifice texting. I super appreciate you getting hold of an admin for me!
  • Ali Ali Posts: 6,735FreedomPop Master, Test Role, iOS Master ✭✭✭✭✭
    @Clark Landry By any chance are you on the unlimited plan and you've used over 1GB? These speeds reflect throttled 4G/3G when high speed data is used up.
  • Clark LandryClark Landry Posts: 71FreedomPop Newbie
    @Ali Yes, I am on the unlimited plan. And yes, I am being throttled to 3G speeds as I'm past the 1GB... but 60Kb/s is not 3G speeds, which are required by law to be at least 200Kb/s. The tower I'm connecting to via LTE is only two floors up - I get full bars at all times on LTE mode connecting to it and was hitting 14Mb/s consistently before my 1 gig was up. This is purely a throttling issue.

    In fact, according to this link from Sprint explaining their network speeds it seems like I'm only getting the bandwidth of Sprint's normal cell (2G) network.
  • Clark LandryClark Landry Posts: 71FreedomPop Newbie
    @Ali @djinks

    So rather than wait around while nobody does anything, I decided to turn to the internet and try to figure things out for myself. I'm not sure how much you guys are "chatroom moderators" as opposed to actual technicians, but I'm hoping that this isn't beyond your understanding. Long story short, I grabbed an SQLite app and found out that my telephony.db file (in the data/data/ directory) is missing the following four lines:

    23 APN0 LTE ota
    24 APN0 EHRPD ota
    25 APN2 LTE internet
    26 APN2 EHRPD internet

    There's also a bunch of other details in other columns on those rows, but I omitted that for the sake of brevity. Anyway, I was wondering if those missing lines could be the cause of my slow data speeds. I tried to add the lines to the file and the changes wouldn't stick, so I did a factory reset. Lo and behold, the missing entries were there when all was said and done! Then I did a PRL and profile update. I opened the telephony.db file and noticed that the entries were ONCE AGAIN missing and that I was unable to add them back.

    This obviously has something to do with FreedomPop's settings for my service. I've gone through all the trouble of taking MANY hours as a complete phone newbie to actually troubleshoot the problem; now it's your turn to step up to the plate and fix things. I am VERY upset that my service has been so terrible all month and that it's been so difficult to get through to you people - multiple threads and posts I've tried to make regarding this problem never made it past being "reviewed". I've missed MANY important phone calls and texts. One of them being a job offer, so perhaps you can understand my SUPREME frustration. I'm also miffed that I - who am COMPLETELY unfamiliar with cell technology - am the one who had to figure this stuff out.

    Mere anger doesn't begin to explain my emotions, but I'm trying to be cordial here and not vent about how ripped off and let down I feel right now. Please... just make this right. My wife is less than two weeks away from giving birth to our child, and I REALLY DON'T WANT TO MISS BEING THERE FOR IT BECAUSE MY PHONE SERVICE IS BROKEN.
  • Jorge Jorge Posts: 3,380 admin
    @Clark Landry Hello Clark, we really wouldn't want that to happen! I will have an agent further assist you with your issue. Please check the email associated with your forum profile as an agent will contact you there :+1:
  • Clark LandryClark Landry Posts: 71FreedomPop Newbie
    @Jorge M. I was contacted by the agent who obviously didn't read the whole thread and basically just wrote "you're on 3G, not 4G, and that's why your data is slow". I wrote back immediately informing them that I'm getting 2G speed not 3G, but have not yet received a response.

    The other reply I tried to write to this thread didn't get past the "review" process I guess. Basically, the agent was absolutely no help.
  • djinksdjinks Posts: 1,270FreedomPop Newbie, FreedomPop Expert ✭✭✭✭
    @Clark Landry
    First I am just a forum volunteer so not the FP technical person. I do have a L720T and the following may be useful to share with your technical contact. Also, is your S4 L720T Sprint-branded or FreedomPop branded? If FreedomPop, and still within the 90 day warranty period, you might want to consider a return.

    On CDMA-only, what does it say under Settings->More->About Phone->Status for Mobile network type and Signal Strength?
    CDMA - EvDo Rev. A is 3G.
    CDMA -1xRTT is 2G

  • Clark LandryClark Landry Posts: 71FreedomPop Newbie
    @djinks It's Sprint branded.

    Mobile network type: CDMA - EvDo rev. A
    Signal Strength: -72 dBm 8 asu

    Mobile network type: LTE
    Signal strength: -80 dBm 59 asu

    I am getting a particularly great signal today. My speeds are still capped at 60 kb/s. I think I might have figured out the problem, at least with the constant PRL updates. There's this program on my phone called "Sprint Connections Optimizer". It pops up now and then asking me to allow it to do its thing, but I don't like the permissions it requires and information it spies on so I always uncheck the box it. Still, it seems to be running in the background or something because I get frequent notices and nagging from it.

    As far as I can tell, this is the program on my phone which is updating my PRL and profile automatically. I would really rather do this myself - can I remove Sprint Connections Optimizer? After the PRL updates and before I hit the "okay" box, I can't receive calls. Since this whole thing happens in silence, I can miss multiple calls prior to checking on my phone and seeing it's nonop until I push "okay"
  • djinksdjinks Posts: 1,270FreedomPop Newbie, FreedomPop Expert ✭✭✭✭
    edited May 2015 #22
    @Clark Landry
    Yes you are getting good signal in 3G as well as 4G. Maybe it is a prl problem. I don't know if the Samsung Optimizer is doing the Update Profile and Update PRL. I think it has more to do with WiFi connections and switching between data modes. See this:!/

    I do not have more to suggest. It sorta sounds like the PRL is wrong but I don't have any PRLs that you should try. You have done Update PRL already. You might try playing with some you find over at XDA, but I have never needed to do that.

    Are you willing to try a factory reset? If so, backup all important data first!
    Factory Reset is found under Settings->Accounts->Backup and Reset
    Oh nevermind. I see you have done a Factory Reset.
  • djinksdjinks Posts: 1,270FreedomPop Newbie, FreedomPop Expert ✭✭✭✭
    edited May 2015 #23
    @Clark Landry
    Are you rooted? If so, take a look at this thread on XDA:

    I tried this on my Note 3. My 3g here at the house is:
    Mobile network type: CDMA - EvDo rev. A
    Signal Strength: -100 dBm 1 asu

    Speed test (OOKLA) results (Mbps):
    Before: Down 0.49 Up 0.19 Ping 71
    Tweak: Down 0.89 Up 0.33 Ping 52
    W/Script Down 0.80 Up 0.09 Ping 58

    Granted the Note 3 seems to have a better radio than my S4.
    I tried playing with the script settings and I think the script was inconclusive, but your mileage may vary.

    I wonder if flashing a different modem may clear up the problem.
    What is your baseband version and Build Number? OS version?
    Post edited by djinks on
  • djinksdjinks Posts: 1,270FreedomPop Newbie, FreedomPop Expert ✭✭✭✭
    edited May 2015 #24
    @Clark Landry
    Do you have a support ticket on this issue? Ali suggested you ask for a plan reset/refresh on the FreedomPop side. He thinks the MDN is corrupted and that is de-prioritizing your speed.
  • Clark LandryClark Landry Posts: 71FreedomPop Newbie
    @djinks What is the MDN and how do I get it reset/refreshed? My "support ticket" was just someone emailing me to say I'm out of 4G data and then I never got a response back when I clarified what exactly the problem is.

    My plan restarts on the 9th and today is the 9th. I don't know what time my plan is going to restart, though.
  • djinksdjinks Posts: 1,270FreedomPop Newbie, FreedomPop Expert ✭✭✭✭
    I asked Jorge for a refresh.
Sign In or Register to comment.