**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

[Solved] No Internet Connection On Freedom Stick 250u

Paul SchmidtPaul Schmidt Posts: 9FreedomPop Newbie
edited July 2015 in Freedom Stick 250U (3G/4G) #1
I purchased the Freedom stick about 2 months ago, but only started to use it yesterday. It worked every time I checked it throughout the day, disconnecting the connection in between. I am using Ubuntu Linux 14.04.

This morning I tried to connect, it said it was connecting, but I couldn't get on the internet. I then loaded the Sprint software on a Win 7 box and ran that. It too would also connect, but it only would go to a "Sprint Activation" page. Whats going on?

image
Post edited by Paul Schmidt on

Comments

  • djinksdjinks Posts: 1,270FreedomPop Newbie, FreedomPop Expert ✭✭✭✭
    edited May 2015 #2
    According to the notice you displayed, I would say you were on a free plan and have used all your free data. Free plans for the USB Modems do not include 3G. You must upgrade your data plan to one that includes 3G.
  • Paul SchmidtPaul Schmidt Posts: 9FreedomPop Newbie
    Nope, I've used 197 MB of 500 MB. It works on day one, but not on day two. And it is actually charging me data usage even when I can't connect to the internet.
  • Ali Ali Posts: 6,735FreedomPop Master, Test Role, iOS Master ✭✭✭✭✭
    @Paul Schmidt It appears you aren't on our 3G plan. Please upgrade to resolve this issue.
  • Paul SchmidtPaul Schmidt Posts: 9FreedomPop Newbie
    That makes no sense. I am connecting via 4G, which I did on the first day. My Freedompop phone connects via 4G, no problem. A device advertised having 500MB free should not be required to have a pay plan. I was going to consider a pay plan if it worked consistently, but now I have serious reservations.
  • Paul SchmidtPaul Schmidt Posts: 9FreedomPop Newbie
    OK, If I have the correct understanding of the lights, it may have never actually connected to the 3G network. The only light that has ever lit up is the 4G one.

  • Paul SchmidtPaul Schmidt Posts: 9FreedomPop Newbie
    And before anyone asks, I do have 4G coverage in my area.


  • Paul SchmidtPaul Schmidt Posts: 9FreedomPop Newbie
    OK Update

    You guys were correct about needing a 3G plan. I'll admit it, I was wrong. What was misleading is that the 4G the Freedom Stick uses is 4G WiMax, and not 4G LTE. I have good coverage for LTE, but none for WiMax. I subscribed to the basic 3G/4G plan and it works again.

    What I don't understand is why it worked for the first day.
  • WUYI  LIWUYI LI Posts: 45FreedomPop Newbie
    Hi, Paul. I have the same USB stick, 250U. However, I failed to get connected. How did you set it up? I just manually created a "Sprint" mobile broadband, with dial number #777, no luck so far.
  •  Don Yu1 Don Yu1 Posts: 4FreedomPop Newbie
    I have the same problem. Except I know for sure we have Wimax coverage because I have another 250u and it connects perfectly fine, whereas my first 250u says connected to 4g on the Sprint smartview menu, but then accesses nothing if I don't have another internet source. HELP! I have a PM in to Jay_FreedomPop from another thread May 23 but no response yet. This first 250u worked fine a month or 2 ago, maybe the account needs some kind of refresh/reactivation?
  •  Don Yu1 Don Yu1 Posts: 4FreedomPop Newbie
    My 250u used to connect a month or 2 ago but not anymore. We have a 2nd 250u in the house and that one connects fine, so we have a usable wimax signal. Maybe my device needs a reactivation/refresh? PM in to Jay_FreedomPop from another 250u thread sent May 23, no response yet.
  • Paul SchmidtPaul Schmidt Posts: 9FreedomPop Newbie
    WUYI LI said:

    Hi, Paul. I have the same USB stick, 250U. However, I failed to get connected. How did you set it up? I just manually created a "Sprint" mobile broadband, with dial number #777, no luck so far.

    I did the same thing as you. I don't know what version of Linux you are using, but I have Lubuntu. There should be a network icon in the taskbar. Right-click on it and make sure "Enable Mobile Broadband" has a check next to it. Then you should be able to click on the "connect" selection for the Sprint connection.
  • Paul SchmidtPaul Schmidt Posts: 9FreedomPop Newbie
    @Don Yu1
    I'm not sure, but I believe they give a one month trial for 3G. That would explain why it worked at first, but not later. As for the Sprint application, it's not used in Linux. To fix your problem I would recommend using Linux instead of Windows. :)
Sign In or Register to comment.