Upgraded global sim to LTE sim. Activated new SIM, but not getting any signal.

mama tabletmama tablet Posts: 2FreedomPop Newbie
I've updated the APN, but still no signal.
I swapped with a second LTE SIM, and second SIM worked. Used first (new) LTE SIM, and still no signal. This proves the problem is not with the phone, or the APN setting, but the SIM/account.
Does it need to be reactivated again on the Freedompop CS end??
Thank you~


  • Rich Sias (16th)Rich Sias (16th) Posts: 3,274FreedomPop Newbie, FreedomPop Master, FreedomPop Expert ✭✭✭✭✭
    @mama tablet, It has to be a fix on that account on the FreedomPop Servers. Need attention of an admin here to check it. Have your ICCID ready of the 'funny' SIM.
    @Karina @AlejandraG @Maria M.
    Be my Valentine ZTE, Victory, LG Volt, 803S, & 4 SIMs
  • moapys1moapys1 Posts: 10FreedomPop Newbie
    Be mindful that presumably pre-activated SIMs are, often, not: Despite it being recognized and showing default carrier "bars" (e.g. AT&T), no data service will exist without the required activation step with F/P.
This discussion has been closed.