Want to activate S3, was told it was partially locked? and to open incident

Alan LiveranceAlan Liverance Posts: 0FreedomPop Newbie
I have a Samsung S3 that I need to activate on my account since my HTC Evo died. So I am without service now and would like to activate my old Samsung. I called in and provided my MEI and was told the model (SPHL710KBB) has some sort of issue that is being worked on to allow for activation. Any idea when I can re-request the activation?


  • hankjrodhankjrod Posts: 368FreedomPop Newbie, FreedomPop Expert ✭✭✭
    Try again now. Someone reported on FB that S3's are working now, although I didn't see any confirmation by anyone else.
  • Ali Ali Posts: 6,705FreedomPop Master, Test Role, iOS Master ✭✭✭✭✭
    The SIII's are now fixed, just make sure that the device in question has not been activated for a week and the ESN is clean, and you would be good to go.
  • M.A. II LopezM.A. II Lopez Posts: 1,163FreedomPop Master, FreedomPop Expert ✭✭✭
    @Alan Liverance can you report to us if the phone ever activated?
  • Rodolfo  ArmasRodolfo Armas Posts: 4FreedomPop Newbie
    I received my S3 today and it will not accept my E-mail address to activate it. I also tried to call support no answer.
  • [Deleted User][Deleted User] Posts: 31
    @Rodolfo Armas‌ - I looked into your account and see that your device is now activated. Are you still having issues?
This discussion has been closed.