can't make a phone call or browse internet without wifi

Tianyun ZhangTianyun Zhang Posts: 0FreedomPop Newbie
I finally got my S3 phone I ordered a month ago from Freedompop this week.
After calling custom support to activate my phone, I was able to make a call and browse internet while connecting via my home wifi. However once I turn off wifi on my phone, I can't make a call or browse internet. When I make a call without wifi, it shows the calling screen but no dial sound, it simply hung up after about 20 secs. When I try to browse internet without wifi, it always shows "Webpage not available". I tried this in an area with 5 bars(3G) signal.

Here is a list of errors I saw:
1. Whenever I reboot my phone, it automatically launches Hand Free Activation(Self Service). I keep getting this error message:

Sorry - we experienced a system problem during your task. Please dial *2 from your Sprint phone or call 1-888-211-4727 from another phone to complete your task.
Call Customer Care

2. Whenever I tried System Update to update PRL or update Profile, I got (Code:407)Internal Error


  • billinjaxbillinjax Posts: 4FreedomPop Newbie
    I received my S3 yesterday and it's working fine on wifi but wouldn't make a call or browse internet on 4glte. What I tried was this that was posted by @Ali: "Update your PRL and Profile, go to Settings, System Update, and Update PRL and Update Profile. Do that and you're good to go.". He posted this for not actually our problem but I decided to try it. I can now call and browse but my phone now says 3g. So not sure about that but am making progress.
  • M.A. II LopezM.A. II Lopez Posts: 1,163FreedomPop Master, FreedomPop Expert ✭✭✭
    @Taylor can you help out?
  • Jorge Jorge Posts: 3,387 admin
    @Tianyun Zhang@billinjax‌ Have you guys tired doing a MSL reset? If not please PM me and I will send you further instructions along with your MSL number :)
  • M.A. II LopezM.A. II Lopez Posts: 1,163FreedomPop Master, FreedomPop Expert ✭✭✭
    Thanks Jorge M!
  • Tianyun ZhangTianyun Zhang Posts: 0FreedomPop Newbie
    Thank you all for your response. I got error when I tried to update PRL so that way doesn't work for me. I called customer support and tried all the possible ways she told me to reset the phone including reset MSL with 000000 but nothing helps, same problems remain.
    Should I try a different number to reset MSL?
    Do I have to switch to CDMA only since my plan is 500Mb(3G)/month?
    Does anyone successfully passed the Hand free activation? That activation error message seems from Sprint.
  • billinjaxbillinjax Posts: 4FreedomPop Newbie
    edited August 2014 #7
    I do have my S3 working but a couple of times I was not able to receive or make a call. After doing the PRL and Profile update it worked again. I also have an HTC Evo 4G and early on with that I did see on the the notification bar the FP icon which some of the information says I should have but now both phones do not show this. I am trying to use Voice with the Voice + Callback and it's working but it still seems to deduct from the phone minutes and not just use data. People do seen on their callerid my GV number.

    @Jorge M if you do an MSL reset does that erase everything on the phone?
  • Jorge Jorge Posts: 3,387 admin
    @billinjax‌ Yes, a MSL reset will wipe your phones information and reset it back to its Factory Default Settings.
  • Tianyun ZhangTianyun Zhang Posts: 0FreedomPop Newbie
    @Jorge M ‌ Could you send me the MSL number for my S3? It looks 000000 was not the correct MSL# for my phone. It might just reboot when I entered the code twice.
  • Jorge Jorge Posts: 3,387 admin
    @Tianyun Zhang‌ Hey Tianyun, sorry for the late repsonse! Your MSL code is: 754687
  • Tianyun ZhangTianyun Zhang Posts: 0FreedomPop Newbie
    I actually find my MSL# using a program from this link:
    No other apps like GetMyMSL and connectbot work for me.

    However after MSL resetting, I still got the same problems.

    After a few tries, I finally got my phone working now without wifi.
    Here is what I did:
    I disabled wifi. Then reboot the phone by pressing power button and home button together. After reboot, the phone just have 3G enabled, then magically my phone passed the activation successfully. After activation, I can update PRL and Profile. Finally for the first time, I can browse internet using 3G.
    After updating freedompop config, I can also make a call using 3G.

    It seems to me enabling wifi may affect my activation. I have to reboot it without wifi.
  • Jorge Jorge Posts: 3,387 admin
Sign In or Register to comment.