No incoming calls or texts. Or outgoing.

Chris BarquinChris Barquin Posts: 0FreedomPop Newbie
I just got my FP phone and it's been a total bummer. It's very very buggy. My S3 won't take a call if it's been idle for more than 10 min. If I unlock it and try to make a call nothing.
When trying to call out, I type the number in and hit call but it wipes my number and the calling screen dose not come up.
My current fix for this is quit the messaging app in the task manager on my phone and reopening it. I can then make and receive calls, but only for 10 mins. After the phone being in idle for more then 10 mins it won't take a call.


  • Jorge Jorge Posts: 3,387 admin
    @Chris Barquin‌ Hey Chris, have you updated our latest version of our messenger app through the Google Play store, if so then also try this:

    1. Select the menu button (located to the right of the home button)
    2. Tap settings, then scroll down to system updates
    3. Select update profile and let it run fully (may take up to 90 seconds)
    4. After the network profile is updated, repeat the same steps, but this time select update PRL instead of update profile

    You should be able to use our service without any issues now! You can also make sure your FreedomPop apps are up to date by checking in the Google Play store (make sure you are logged in/ synced with your Google account).
  • Chris BarquinChris Barquin Posts: 0FreedomPop Newbie
    They have been updated both prl & profile and I'm still having the issue. Apps are up to date.
    Only thing I haven't been able to do is a msl reset as I don't have the code for that.
  • Lawrence ReissLawrence Reiss Posts: 21FreedomPop Newbie
    I have a similar problem with my Galaxy SIII !

    Have done the steps you describe - update profile, update prl, msl reset. Still cannot get my sprint galaxy s3 to work.

    It will make one call only. After that, it appears to dial and hang up. Not getting any help from tech support. They had me factory reset my phone twice. Lost all data each time. Was supposed to get a call back from someone at higher level about 2 weeks, but it has not happened.

    Data is being received. I sometimes get texts. If I respond, they don't get my response. Same issues whether I am on Wifi or 3g / 4g. I think something is wrong with the way the account is set up at their end.
  • Chris BarquinChris Barquin Posts: 0FreedomPop Newbie
    Eh Hello? How am I suppose get support? I tried calling but after 40 mins of hold I hung up. I don't think anyone was there.
  • M.A. II LopezM.A. II Lopez Posts: 1,163FreedomPop Master, FreedomPop Expert ✭✭✭
    @Chris Barquin‌ try their call back feature instead of waiting that long on the line! If you call early enough they will return your call by noon on most days. Its worked for me every time I have done so. They tell you about it on that opening message when you call, maybe the second one. I think its option 2 though. Can anyone confirm this for me!
  • Chris BarquinChris Barquin Posts: 0FreedomPop Newbie
    Eh I don't know what else to do, still have no help with my phone, it's not worked since the first day I got it. I've done a factory reset & profile & PRL update. Still same issue. Apps were updated after the reset as well. Phone will not receive call after it's been idle. If I close the messaging app and reopen it then it will work for about 10 mins. Had it work for up to 40 mins or so but not for much more.
  • M.A. II LopezM.A. II Lopez Posts: 1,163FreedomPop Master, FreedomPop Expert ✭✭✭
    @Jorge M ‌ can you help Chris out?
  • Jorge Jorge Posts: 3,387 admin
    @Chris Barquin‌ Sorry about the delay Chris! Your MSL code is:109102
  • Chris BarquinChris Barquin Posts: 0FreedomPop Newbie

    Alright I'll try and be as detailed as I can about this issue.

    The phone will not ring if idle more than 15-30 mins since working. The call is not recorded on the phone log however if a voicemail is left the phone will alert of the voice mail shortly after it's been left.
    Secondly text messages do not alert but are recorded once phone has been active.
    Lastly Sometime the call going to the FP phone will go directly to Voicemail, sometime it will go to voice mail at 24 seconds, sometimes at 45+ seconds, while the phone is not ringing. When ringing it's a normally about 36 second to voicemail.

    I've Done: Factory Reset then update profile, PRL & FP apps. Still same issue. I did a MSL reset and did updates and same issue.

    Currently This is fixable by force closing the app then reopening the app. Then everything is working fine for about 15-30 mins.

    This seems like an app bug because it only takes a restart of the app to fix the issues.
  • Chris BarquinChris Barquin Posts: 0FreedomPop Newbie
    Another day another $1.67 for my non-working phone... Am I going to be credited for this time I can't even use the phone?
  • Chris BarquinChris Barquin Posts: 0FreedomPop Newbie
    Hello Anyone can I get some help with my phone?
  • @Chris Barquin‌ It sounds like you have a defective device. If you private message me your contact information, I can have a tech agent call you to discuss a possible exchange RMA.
    In regards to your $1.67 charge, I am not seeing that anywhere in your account. Would you mind also including a screenshot of the charge in your private message to me? Thank you!
  • Chris BarquinChris Barquin Posts: 0FreedomPop Newbie
    Alright it's been 2 weeks today since I opened this thread and haven't been able to get anything useful done. PM'd K_Ber 8/7 and still no response this is terrible.
  • @Chris Barquin‌ Sorry about that, Chris. I have just responded to your PM.
  • Chris BarquinChris Barquin Posts: 0FreedomPop Newbie
    Just updating the situation here. K_Ber asked for my phone number so someone from the office could call on 8/11 I provided the info and got a call at 5:30 pm I couldn't pick up the phone because I was driving home. Freedom pop didn't bother to leave a message in fact if I didn't Google the number I wouldn't have known it was Freedom pop. It was one of those 1-800 numbers I could have easily mistaken it for a telemarketer. So After missing the call on the 11th I pm'd K_Berr informing him I missed the call. He said someone would call me back 8/12 and no one called. As I write this it's AM 8/13 and I just PM'd @K_Ber to inform him no one called me yesterday.
    18 days since I opened this thread still no help, bummer.
  • M.A. II LopezM.A. II Lopez Posts: 1,163FreedomPop Master, FreedomPop Expert ✭✭✭
    Chris hang in there, they will get to you, @K_Ber‌ will respond, we still have Friday so there is time to get that call!
  • hankjrodhankjrod Posts: 368FreedomPop Newbie, FreedomPop Expert ✭✭✭
    @Chris Barquin‌ When you did a msl reset and factory reset did you restore your phone from your google account. If so, don't. It may be that another app you have is causing the issue, or restoring your account redownloads the setting that is causing it. After a msl reset sign in to your google account, don't restore settings, do all updates of preinstalled apps, downoad the fp messaging app and nothing else. If you have already given this a try, then you probably do have a defective device. (However, earlier on I had this problem with an S2 and I just had to make sure i did a clean reset).

  • madeinhawaiimadeinhawaii Posts: 4FreedomPop Newbie
    No incoming text or calls - outgoing only Desire 510
Sign In or Register to comment.