signing in forever

odradekodradek Posts: 6FreedomPop Newbie
I just got my phone.
It insists on connecting to WiFi.
I connect to WiFi.
It tells me to sign in to Google.
I type in my username and password.
It says, "Signing in. This can take a few minutes."
Hours later, it's still signing in.
"Cancel" does nothing; I must restart.
This is all my telephone can do.


  • [Deleted User][Deleted User] Posts: 12
    Hello @odradek I am sorry to hear that you are having this issue, I will be glad to have a forum agent look into this for you. Please check the email associated with your forum profile as an agent will contact you. Replying to the email from support can be done as you would a regular email (no need to log-in into Zendesk). :3
  • odradekodradek Posts: 6FreedomPop Newbie
    Thank you. Resetting my phone allowed me to log in to Google. Now:

    I have tried calling my landline:
    1. I go into dialer.
    2. I type in my number.
    3. Nothing happens.
    4. I press the green telephone button at the bottom of the keypad.
    5. The number disappears from the display and nothing happens.

    I have tried calling my cellphone from the landline:
    1. The number the website tells me does not make my phone ring.
    2. The number my phone tells me gives me a message about being an invalid number.

    So, I can neither place nor receive phone calls.
  • RossfuzRossfuz Posts: 116FreedomPop Newbie, FreedomPop Expert ✭✭✭
    go to settings, application manager and clear data. restart. I sometimes have to do that then everything is fine.
  • odradekodradek Posts: 6FreedomPop Newbie
    Thank you. I tried doing this. The only app there was Google Play. I cleared data from it and restarted. Now, when I try to dial a number the screen goes grey and nothing happens. When I hit the home button it says that messaging isn't responding and asks me to stop it. I still can't make a call.

    I also tried calling my cellphone. It doesn't ring.
  • odradekodradek Posts: 6FreedomPop Newbie
    After many tries, it appeared to make one outgoing call. My landline did not ring, and I got a recording saying that "the number I have dialed is incorrect." It gives me no hint about how it is incorrect.

    Also, I can never connect to the Google Play store.
  • odradekodradek Posts: 6FreedomPop Newbie
    I have managed to connect to Google Play by using 4G, but even with 4G on the dialer does nothing. I can't call out from the cellphone and it can't receive incoming calls. The same goes for email.
  • djinksdjinks Posts: 1,270FreedomPop Newbie, FreedomPop Expert ✭✭✭✭
    Are you using the FreedomPop Messaging app? The native dialer should not be used. When you mention the green telephone button, I believe that is the native dialer app.
  • odradekodradek Posts: 6FreedomPop Newbie
    Thank you. I managed to connect to WiFi via tethering to a friend's phone and update the app. Now it appears to work, green button and all.
Sign In or Register to comment.