Another MiFi 4082 that won't connect to internet

FahfoofnikFahfoofnik Posts: 1FreedomPop Newbie
Hi there,

I did a factory reset on my MiFi 4082. Now it's asking for a password, and I've tried "freedompop" and "admin," and I can't connect to re-set-up my FreedomPop MiFi. The network shows "FreedomPop_C33." No password works, including entering that SSID in lower case letters and exactly as the SSID shows.

I did a factory reset as I simply could not connect to the internet any more. My devices would show that they were connected, but no internet ever went out. I tried all the usual troubleshooting steps found on the FP website and the web. No dice.

My account is on the free program and I pay for rollover, I have a good amount of data waiting for me to use…but I can't get in to this darn thing.

Help! Anyone?


  • jimindenverjimindenver Posts: 149FreedomPop Newbie, FreedomPop Expert ✭✭✭
    Try PASSWORD, password and one I had was swiadmin
  • [Deleted User][Deleted User] Posts: 12
    Hello @Fahfoofnik

    I would be glad to assist you with this, if what @jimindenver suggested did not help please send me a private message with the account email for your MiFi and I will reset the password for you! :3
  • jimindenverjimindenver Posts: 149FreedomPop Newbie, FreedomPop Expert ✭✭✭
    I forgot admin
  • Bonnie  Hayes Bonnie Hayes Posts: 1FreedomPop Newbie
    I have similar problem. Did a hard reset - freedompop as password was invalid, but admin worked. However, when it tried to activate it came up with error and could not activate. Help.
Sign In or Register to comment.